LED Intensity and RGBW fixure individual faders


#1

Hey Folks,

Ok, so I had a similar question about a month ago assigning virtual faders to individual colors in ONYX. The thread was here: LED Colors with Submasters?

David assisted me in getting individual colors assigned to Overrides (Each channel color intensity was one in the same, no intensity slider to deal with).

I’ve now added a new fixture (Stage Right COB LED Ellipsoidal) which has four colors RGBW and a separate intensity.

Since my other LED lights are set w/o an intensity (color brightness strictly controlled by the color slider), the previous forum example worked for those fixtures.

So, I select the fixture. Set all colors to 0%.
Then select RED, set it to 100 %.
Select “Clear Channel” on the GREEN, BLUE, and WHITE.
Hit “Record” leaving the Record values default (Values, fixture, source at default)
Select a channel on the bank, Give it a name, select “Override”.

image
image

When I go to that slider, it does nothing.
image

I am not sure what I am doing incorrectly here.

Thanks,

James


#2

Either add another fader with only Intensity at 100% for your new fixtures, or look into the virtual dimmer setting for your original fixtures. There is a post somewhere on here regarding that, or you can check the manual. Unfortunately you will have to patch them again if you go that route.


#3

So, I did attempt to add a “Submaster” (Also tried it as a Override) for the intensity.
I selected the fixture.
I set intensity to 100%. Unit goes 100% white (All color channels are unloaded).
image
image

So when the RGB channels are “Cleared”, the percentages go 100% (even if I set them to zero first, they pop back up when clearing channel).
When I then go to the Intensity channel, and set that to 100%, I get white (presuming because RGB are at 100% even though they are cleared).

Now, when I go to my Submaster slider, bringing it up gives me white (RGB 100%).
When I go to my RED fader (recording as in originally mentioned thread), it does nothing.

You also mention looking into the virtual dimmer setting for your original fixtures. Not sure how to do that.


#4

Before we get too far, I just want to mention that im no expert by any means… I’m sure there are more knowledgeable people on here, but getting them to comment can be slow. THAT BEING SAID…

I think Onyx defaults all the color channels to full in the background for reasons beyond me. I have gotten around this by making a separate playback button with all color channels of all my fixtures at 0%. In the cue settings I have the “stay alive” button on. This way everything will be black while I’m programming. If you have a programmer window created, you will see that isnt a R 0% or G 0% or B 0% under color. This means you can still program correctly. Without this cue, as you’ve noticed, everything will go back to rgb white as soon as you clear out.

You’re Intensity submaster sounds like it’s working correctly, it just has the weird full color on in the background. I’m not sure if there is a way to turn this off or not. Once you make that cue and activate it, having your intensity fader at full will do nothing, but the fixtures dimmer will still be activating. You can verify this in the active cuelist window (make sure your intensity fader is selected), and it should show whatever that fixture profile is named with the intensity at 100%. Next bring up the red fader and it should turn red.

I’m hope this helps, I’m not at home to take screenshots of Onyx. I have also noticed this forum seems to be dying off. I dont use facebook, but there is also a page for Onyx. It may be more active.

EDIT
I forgot to mention the virtual dimmer is a setting you have to activate as you patch a fixture without a dedicated dimmer channel. It’s pretty useful, but as I said you will have to repatch your rgb profiles.


#5

RGB are set to 100% on additive fixtures so @ FULL creates light output just like a white fixture with a CMY system. This is quite common practice on many lighting consoles.


#6

Thanks for the info Matthias! Is there a way to turn off this feature that I’m missing or is making a cue like I stated the only way around it?


#7

You can customize all default values and save them in the default preset.


#8

So, I am having no luck on how to do this. I can record an intensity w/a Submaster, but that brings up 100% white (RGB), and does nothing for anything else I try to record.

I cannot figure out how to make an Override for each color. If I bring up the above-mentioned Submaster, like I said, all white. If I use the Override, does nothing.

I’m not even sure about the virtual dimmer discussion. I attempted to patch a new fixture, and see if there were any additional settings when working through the patch, but I see nothing different.

An further help would be appreciated. I am self taught, worked through many of the online youtube videos.

Thanks,

James


#9

James,

Since your new fixture includes a “dimmer” channel the setup to create “override color faders” is a little different and can be accomplished a few different ways.

Option 1 - see if the new light has a 4 channel mode. RGBW. If so you could place it into 4 channel mode and then follow the same procedure as describe by David for each color. In short, set defaults of colors to 0% and make each color fader an override at 100%. As Matthias stated, by default an additive color system defaults RGB at 100% so an @FULL command gives light output.

Option 2 - Leave your light in a 5 channel mode. RGBW and Intensity. In this you can still use the override method from above, however you also have to set the intensity channel to full for for each color override. In short, you will set your color defaults to 0% again. This time when you go to record your override color, you will have the color and the intensity channel recorded into the override cue. This way, when you bring up the color it also brings up the intensity. Otherwise you would bring up the color but have 0% light output. So you need to allow the intensity channel to “open up” also.

Option 3 - Similar to option 2, and still using a 5 channel mode, but rather than recording intensity into the overrides create a separate submaster cue to turn it on. This allows you to create a color with overrides, but control the intensity separately. You would again set defaults for colors to 0% and record your color faders like option 1. However, you now need to create a cue to allow light output. This can be done as a submaster, which only controls intensity. Or as a cuelist which would also require some form of a “trigger”. Like the press of a “Go Button”. I’d recommend the submaster. You would select only the intensity channel of the light and record it at 100% to a submaster. This submaster will now need to be “active” to allow the color mixing of the overrides to be output.

Option 4 - leave all defaults alone and use presets to set color and intensity. This option depends on how you operate overall. Are you using the 3 to 5 channels to create a color and just leave it because that’s what you used to do? Are you actively mixing colors on the fly? Can your “workflow” change to have cleaner and more efficient programming? Presets can be a huge help, but also require some planning and managing so you don’t quickly clutter a show file.

Again depending on your situation and what your trying to accomplish, one of these options should work. If you want, and are willing to share your show file, I can take a look and maybe create a few specific examples and send it back. If your interested, just send me a message.

Also, in options 1, 2, and 3 when you set the color defaults to zero the @FULL command and Highlight won’t work. Since they rely on the RGB values to be at 100%.

Hope this helps,

Watson


#10

Hey Watson,

Thank you for responding.

Option 1 won’t work. The particular LED Ellipsoidal only offers a 9 channel mode, of which we are interesting in five of those channels (RGBW & Intensity). A four channel mode would have been nice.

Option 2 (or 3) is most likely what I am striving towards.

The Setting is a church (my church), the lights will normally be set-and-forget for most of the time. With volunteers that previously used a hardware solution (Strand 200plus console) and all programmed to be used as submaster sliders, doing anything more complicated tends to scare off the volunteers.

Attached is my latest Show file.WBF-Show_2019-04-15_0826_Build_4_0_1010_0-RGBW-In-Progress2.OnyxShow (1.4 MB)

Thanks again for everyone pitching in.

EDIT: Bank 6 was where I would land these sliders. The lights in question are 5101 through 5104 (I have one of these lights here at the house to try to get working on my test box).
I do have them grouped:
All four are in REAR STAGE Ellipsoidal Group
5101 & 5104 are called REAR STAGE ELP Outer Group
5102 & 5103 are called REAR STAGE ELP Inner Group


#11

try this
the defult of the fixture is intensity at -0- and RGB at -0-

WBF-Show_2019-04-15_0826_Build_4_0_1010_0-RGBW_at_-0-In-Progress2.OnyxShow (1.4 MB)


#12

Matt,

Thanks for setting that up for James. I currently only have access to 4.2.1045. Did you also create the overrides or just set the defaults?

James - just for clarification. The modified show file provided by Matt would be for the option 2 scenario as you indicated you were wanting to head towards. So any overrides will need intensity included in them.

Watson


#13

Matt, Watson, thanks so much for this help. I was able to set up the sliders.

Matt, how were you able to set the default of RGB to zero, and to remain at zero when clearing the channel of each color? Would be good for learning purposes.

Thanks again…


#14

James,

If you go back to the first post in this thread where you talk about David giving you the example. The procedure is in that link. You have to clear each of the other channels not needed (right click the color if on pc, if on console hold clear command button and press color attribute encoder.)

Watson


#15

Actually, that did not work originally. When you clicked on Clear Channel, the percentage would jump to 100% (rather than 0%). Thus it was producing white (RGB Style).


#16

What I did was change the default of the lights (5101 to 5104) so that R,G,B are at -0-
to do this for other lights

  1. select the lights you want to change the default value
  2. adjust the light to what you want the default value to be
  3. record this to default preset and merge (on your show file it was view 11)
    you can also find the default preset by right clicking the lock icon and select lunch view then select programmer then select default

You can change the default of any light to be what ever you want it does not need to be color and can also be the intensity or the pan tilt

default is what the light will be doing with nothing in the programmer and no cues running


#17

Matt, I just tried that, and it worked great!

Thanks again for the knowledge…