Win 10 Firewall is blocking M Series Remote

m-pc

#1

We just updated our PC to run M-PC. I can’t seem to let M-PC through the Windows 10 Firewall. My M series remote from my iPhone is detecting M-PC only when Windows Firewall is turned off. I tried adding “C:\Program Files (x86)\Martin Professional\Maxxyz\Binaries\Maxxyz.exe” to programs to allow through, but it still doesn’t work. Any suggestions please?
Thanks!


#2

Chris,

Not sure if I’ll be of much help, but can you provide a few more details to the setup to see if anyone else can. Just to make sure we are all on the same page…what Windows version did you upgrade to? What M-PC version are you running? (Latest or most recent are not helpful answers.) Were you already using this computer to run M-PC with the remote and the upgrade caused this link to “break”? How is your network structured? DHCP enabled or specific IP’s assigned? Personal Wireless Router? IT / Facility managed networked wi-fi?

I am using M-PC (3.70.885.0) running on Windows 10 (1803) in a IT managed network / wi-fi environment and am able to use the remote (as of yesterday). However, I’m not sure how the IT department has the Firewall set. These are both company (House Of Worship) owned devices on a secured technical network with no outside internet access. So all updates are controlled and approved.

Sorry I can’t be of more help. Once you provide more details on your setup maybe the @obsidiancontrol can provide more assistance.

Watson