Windows Update breaks M-PC for the second time in 3 months - what's the plan?


#1

The April cumulative update for Windows 10 1709 prevents files from loading - M-PC sits there and spins at loading show. This update is not uninstallable, so users are screwed.

What’s the plan folks? This is beyond frustrating.

Thanks


#2

Running Windows 10 ver. 1709 Build 16299.371 using MPC 3.70.885.0 with no problem


#3

I have a newer show file created originally on 3.70.885 which worked on two machines prior to the Windows update, and now neither machine can load the file. This other user appears to have the same problem:

Not sure what is your secret sauce, but that’s not my experience.

I’m running that same show file in question now on a 3rd machine that I haven’t updated.


#4

I have 5 machines running MPC
the one on on right now last updated on 4/10


check to make sure you are on the latest update other then that I have no “secret sauce”
I do have one of the 5 machines that takes a lot of time to get past the “Optimizing Data” screen but it is just slow


#5

I launched M-PC without issue after this W10 64 bit computer updated to:

Security update for Adobe Flashplayer KB4093110

Cumulative update KB4093112


#6

I just updated a machine yesterday to Win 10, 64 bit (1709) Build 16299.371 and installed MPC 3.70.885.0 just fine. Show loaded fine. This morning, however, I did have a momentary load issue. Had to restart the machine and then all was fine. And this machine has been know to have slow loading and needing occasional restarts.

I would suggest confirming that all Windows updates have been installed, and check again. Restart your machine and give the system time to log back in and start all the needed OS processes before launching MPC. See what that does for you.

Hope this helps,

Watson


#7

whats the kb number for that update


#8

Three updates were installed in the same package:
KB4099989 Update For Microsoft Windows
KB4093112 Security Update for Microsoft Windows
KB4093110 Security Update for Adobe Flash Player for Windows 10 Version 1709.

An update - I got one of the machines to work - I started a brand new file, then closed the app and was able to load my show. My second machine is still broken and even choosing a new show doesn’t work - it gets stuck at loading forever.

If there are any log files that would be helpful, I would be happy to send them your way.

Thanks for your attention,
TJ


#9

just updated 3 PCs, no problems…


#10

When this happen:

  • Close M-PC via Task Manager

image

  • Double click PrepareForUpgrade

  • Wait 30s, than launch M-PC

#11

Thanks for the procedure - I tried it and it didn’t work. I uninstalled everything and re-installed and it’s working now.

Thanks.