DMX-IN issue with LJ 2.110

Hi everyone,

First of all, here is my setup: Win 10 / LJ 2.110.4 / 2 M-DMX interfaces

I got what seems to be a regular problem encountered by several users, in fact there is no way to operate the DMX IN, the software does not react, the controlled submasters remain at 0 as if they did not receive information.
(with activated option, and configured channels )

I have no way to get a response with my external consoles ( I’ve switched consoles, cables, and adapters too)
I also tested on the 2 interfaces

But when I tested with the DMXin emulator, it worked well

I’ve installed the Elation version of the software but it doesn’t solve the problem

None of the the topics on DMX IN issues on this forum brings solution

I so concluded that it is a problem with the interfaces but I am stucked (as far as I know, the M-DMX no longer has a dedicated driver to install, otherwise it is the first thing I will have done)

Thank you in advance for your help !

Hello ? Anybody here ? Or this forum is as dead as Martin left the LJ before selling its controllers department to Elation ? (FY H*rman by the way !)

2 months later !

Does anyone from Obsidian (which as far as I know is mainly the old team of Martin) could help LJ users ?

This dmx-in issue is a legacy from old version of the software, would it be possible that a fix can be produced ?

Buying the software and a 2nd interface (from legal resellers) costs me about 1100 €, and I’m really furious that I can’t use an essential function like the dmx-in (and I never experienced any similar issue with the universal interface on Win7)

Hi, the M-Series controller team that moved to Obsidian never worked on LightJockey. That developer left Martin over 10 years ago already.
I’ll have a look during the week if I can get DMX In to work. I doubt its the interfaces, they haven’t really changed. Possibly its a Win10 issue.

Hi. By “That developer left Martin over 10 years ago”, do you mean Paul Pelletier ?

Anyway, I hope you’ll be able to find a solution to this problem ! Thanks in advance !

No Paul was not the developer for LightJockey.

OK, I thought he was involved (as he also developed the LJ manager)

Otherwise, have you any news about the interface issues ?

We corrected this issue and will create a new installer in a few days.

Hello, it’s a real good news to hear !

I’ll wait for it (edit: I have to install the software on a brand new PC so it’ll be a perfect test without any corrupted drivers or registry keys !)


Try this revised installer

The issue seems fixed and a new version is posted on the product page