M2GO Controller in Network

Hey Guys,

I don’t know if there is already that kind of instruction and summary around here in this Forum or somwhere else.
But i now finally managed to get my Artnet and my OSC Network work and also manage to make them work together at the same time and i want to share my soution with you if there are maybe another ones with the same Problems i had.

My Setup i use is an M2GO Controller, my Laptop with Realizzer as 3D Simulation Software and my Android Phone with the TouchOSC App.
With this Setup i can completly control my M2GO over the App from my Android Phone and meanwhile also all the DMX Data from the Console is send to my PC with Realizzer running so i see in realtime my 3d Simulation.




Here is what i set up and what i did to make this all work.

For the Artnet Network:
At first I directly Connect the “Remote Network” Connection on the M2Go Console with my Laptop with a normal Lancable.
You can also use a Router or a switch inbetween with the right Configurations but i dont wanna use two routers in my whole Network so a direct connection works fine.
Now the settings i made on the Console and the Laptop
M2GO <-> PC (Realizzer)

  • Ip Adressbereich has to be 2.x.x.x

  • Subnetmask 255.0.0.0
    (+ Firewall Router -> transparent)

  • Firewall PC should be good if “on”

  • M2GO

    • Network Interface 1 (“Ether DMX” Connection on the back of the Console) - Static Ip in Menue->Network->Settings->Interfaces
    • Ip: 2.0.0.2
    • Subnetmask: 255.0.0.0
    • in Interfaces/Static-Ip all Options (sAcn, Maxnet, OSC,…) “OFF”
    • only Artnet Option “On”
    • in Menue->Network->EtherDMX->Artnet: Full broadcast
    • Realizzer (or whatever other Artnetnode you use) should appear in Devices
      (Menue->Network->EtherDMX->Devices)
  • PC

    • Static Ip in Windows-Network->Adapter settings->right Adapter/Connection
    • Ip: 2.0.0.1
    • Subnetmask: 255.0.0.0
    • start Realizzer
    • in Input->DMX Input: select Artnet
    • in Input->Network Settings: select PC Lan-card with right IP (2.0.0.1)
    • controll if signal “arrive” with: Input->DMX Input Window
    • ready

Direct connection m2Go <-> PC with Lancable without Router!!!


For the OSC Network:

  • Ip Adressbereich has to be 192.168.1.x

  • Subnetmask 255.255.255.0

  • Firewall Router -> transparent

  • Firewall PC should be good if “on”

  • M2GO

    • Network Interface 2 (“Remote Network” Connector on the back of the Console)
    • Static Ip in Menue->Network->Settings->Interfaces
    • Ip: 192.168.1.3
    • Subnetmask: 255.255.255.0
    • in Interfaces/Static-Ip all options (sAcn, Maxnet, OSC,…)“OFF”
    • only OSC Option “On”
      *select OSC Device node (i choose the first node)
      *Device Space: 001
      *IP Adress: 192.168.1.4 (adress from Phone or other OSC device)
      *Incomming Port: 9000
      *Outgoing Port: 8000
  • Phone

    • connect over Wlan
    • in “wlan options” on the phone (choose the right wlan network!) select “Static IP”
    • Static Ip: 192.168.1.4
    • Subnetmask: 255.255.255.0
    • open OSC App (TouchOSC Hexler)
    • go to OSC settings
      (Connections->OSC)
      *Host: 192.168.1.3 (adress from M2Go)
      *Incomming Port: 9000
      *Outgoing Port: 8000
      *ZeroConfName: Android
  • Router

    • Thomson Gateway (in my case its a Thomson but should work with any type)
    • Gateway Ip: 192.168.1.1
    • Subnetmask: 255.255.255.0
    • DHCP IP 192.168.1.2 - 192.168.1.100

After you made all Settings open OSC App on your phone and press refresh button (on the last Tab in the App) and also press refresh button in the M2Go Settings ((Menue->Network->OSC->Devices->Tasks)
As soon as the connection has build up Cuelist names and all other names will be transfered and be shown in the OSC App on your phone.




i hope i didn’t forget something and i hope i could help people with the same problems i had with all the connection settings. The IP adress ranges for Artnet and OSC are really important! It wont work otherwise with other ip ranges (in my case).

Best regards
Markus

Thank you sharing, Markus!

Why swapping the Remote and the EtherDMX ports?

The Remote should be on 192.168.x.x range while the EtherDMX should stay in 2.x range.

Oh okay yea youre right i accidently swaped that two names in the post i wrote.
I edited that

But just for more understanding. The two ports are two independent ethernet ports which i could configure independent from each other right? Or is this wrong and is there any special in the program maybe?