MSD: Connection from HOG4PC


I am trying to connect my HOG4PC to MSD 3D Visualizer.

What is the correct configuration to use MSD with HOG?

The HOG itself knows about MARTIN as show visualizer but it does not detect it as it does with LightConverse.

Can anybody help?

My best regards,


Hi to all,

Stefan Montanus from LightHouse Support wrote a really good mail explaining how to setup this connection, here it is:

The visualizer communicates with the HOG Connectivity driver to get the DMX values from the HOG, so that needs to be installed on the PC running MSD, and you need to select the external ‘HOG III PC Link’ in MSD ( using the ‘Show Control’ > Follow > ‘Select DMX Connection’ )
You can check if you selected the correct DMX connection by clicking on the blue area in the status bar. It should look something like this.

We also had problems with the connection, and asked Wholehog but never got a satisfactory answer.
After some testing I was able to get the connection working by following these steps :
• Setup the network correctly ( obviously :slight_smile: )
• In the startup screen, select ‘Settings’ and enabling the ‘Run Visualizer Stream’
• Open the HOG show
• In the HOG network settings, change the settings of the Visualizer.
o Set the Visualizer IP Address to the correct ip
o Change the manufacturer to MARTIN

In the Visualizer settings of the HOG, there is a drop down box with Detected Visualizers. When I tested it here, the drop down did not contain the MSD visualizer that was running on another PC, that is why i included Chris Muenchow from wholehog.
So Chris here are some questions for you :
• is there anything that MSD needs to do to make it appear in the detected Visualizers list ?
• what do we need to do, to show the UI of the HOG Connectivity driver ?
• I did not find the step of enabling the ‘Run Visualizer Stream’ in the online document. Is that missing in the document, or should the connection also work without doing the step ?

I can not get the Hog III PC Link to even show up in the Demo version of MSD. I’m assuming the demo version does not have this feature?


that could realy be because you cannot create your own stage in the lite version but you need that in order to set the DMX adresses. So it does not make sense to enable that feature in the lite version, probably.

From the MSD6 demo notes:

MSD From Show Control click “Follow” and choose “Artnet”
HOG4 PC To have an active “Artnet connection” you need a hog DMX Widget
connected with your PC.
After patcing open Network and right click the DP number at Setings
A new window will open.Find the ** Art-net output** and activate the patched universe.
You must set the correct parameters for the Visualiser on the HOG do this
open Network and right click on the Visualiser number.
A new window will open. Click Settings. Fill the Visualiser IP Address and
Visualiser Manufacturer areas…
IMPORTANT : you need a HOG DMX Widget connected with the PC or laptop.

1 Like