MSD-Vectorworks 2017 Menu Item

The MSDExport is not showing up in vectorworks 2017. Very strange. Has anyone else added it? I have added it to the plugin folder, but not there once I open vectorworks to add it to menu.

We placed the files ‘MSDExport 2017.vlb’ and ‘MSDExport 2017.vwr’ in the folder ‘Program Files/Vectorworks 2017/Plug-ins’, and that seems to work.

You do need to have your Martin One-Key connected - and Codemeter control center running - on the computer that has Vectorworks 2017 when you do this, as the plug-in itself needs access to the MSD 6 Pro license on the key.

We also found another way to install the plug-ins, that you can try:

  • First create a zip file containg both the ‘MSDExport 2017.vlb’ and ‘MSDExport 2017.vwr’ files.
  • In Vectorworks open the Plug-in Manager by using the menu ‘Tools > Plug-ins > Plug-in Manager …’.
  • Select the ‘Third-party Plug-ins’ tab.
  • On that tab you can click on the ‘Install…’ button which will open a File Open dialog
  • In this dialog you should select the zip file you just created that holds both the MSDExport 2017 files, and open it.
    After that is done, you will need to restart Vectorworks.

Should you ever need to remove or replace these files, it might be good to know that using the procedure with the Plug-in Manager, Vectorworks will copy the 2 plug-in files to the folder ‘C:\Users<username>\AppData\Roaming\Nemetschek\Vectorworks\2017\Plug-ins’.
(The AppData folder is a ‘hidden’ folder, so it will not be shown by default )

I’m still not having any luck. Please look at the video https://youtu.be/QP1iwXDLqSU

Hi Kevin,

If you use the Plug-in Manager to install the plug-in then the two files should also be in the
‘C:\Users<user>\AppData\Roaming\Nemetschek\Vectorworks\2017\Plug-ins’ folder.
( The Roaming subfolder is hidden ).

Can you check if the two files of the plug-in are located in that folder ?
Can you check if the Codemeter control center is running, and if the key is seen by it.

Confirmed.

That looks all correct.
Up to know this always worked, so we have to dig deeper and probably contact VW support so see if they have any idea why the plug-in is not in the list.

We found something else that might be the problem.
Internally this plugin is called ‘MSD Export2017’ and it is renamed when we create an installer to match the name of the older plug-ins.
It looks like there is a reference somewhere in the main plug-in file that refers to the second plug-in file by name.


26th Jan 2017: We released a new plugin to fix the issue, which is included in version 6.0.1701.26.
(With the name as it should be: ‘MSDExport2017’ without spaces in the name.)

SUCCESS!!

1 Like