NETRON Central Utility - Beta 4

Some additional bug fixes and layout and speed improvements for the Netron Central Utility.

The installer contains updated firmware as well, simply try the firmware update button and see if it pushes to all devices without issues.
We are looking for feedback especially on RDM10 firmware updates.

	Release Notes for NETRON Central Utility
		(C) 2022 - Obsidian Control Systems

V0.1.004 (08/13/2022)

Improved device table layout
Improved device discovery speed and UI feedback
Increased speed of device online/offline monitoring
Improved reliability and speed of firmware updates
Added “About” screen with Version Number, Release Notes, Help File

V0.1.1001 (08/01/2022)

Added status feedback LED to show nodes online/offline
Improved discovery speed
UI recalls position and size

V (06/23/2022)

First public beta version
Supports discovery on all network ports over LLRP
Allows IP configuration, Identify
Firmware updates for one or multiple devices
Direct access to all device web pages

1 Like

Hey Matthias,

For Beta 3 you asked that we uninstall the previous version before installing Beta 3. Does this apply to Beta 4 as well? Will this be required for all CLU updates?

Thanks in advance,


try to install it over. It is no longer required to uninstall, we adjusted the installer and executables

Hi Matthias,

Still having loads of issues with the RDM10 units and this app.

I have one that keep’s coming up saying its a EN12 even after its been flashed with the new firmware.

If I have more then 3 devices on the same network then ONYX starts losing connections to the nodes and RDM units.

I tried to plugging in just one unit at a time. So far none of the EN12 units will show up on the app. I can see them fine in ONYX.

Quite often nothing at all turns up under the device list at all.

Firewalls all turned off and no AV on.

I can ping them fine, I can also go to the webpage via ONYX fine. Even with ONYX not on the same network nothing will show up.

I shall continue testing different avenues to see where its going wrong.



Finally had 2 seconds to try clu. It didnt come up when i fid a scan. It shows up in onyx no problem. Unit is en4 fresh out of the box with firmware 2.8. Let me know what elae you would like me to try. I have urned advast off as well. Windows 10 computer with 2. Range ip address.

seems a failed firewall install. check if ‘clu.exe’ is showing as an exemption for public and private internet.

Looks like Beta 4 installed over just fine. I do believe the machine I tried it on was still on Beta 2.

I added clu. Then it Looks like it installs under netron central utility. Private wasnt ticked and now is and works. Well it finds it. I can click the actual unit and looksmlike i can change settings. As well as identify. But the side tab nothing seems to work. It populated with devices presets ect. But nothing happens if i click on it.

Hi Matthias, I was just curious — with this beta, is it more the Central Utility that is beta or both the utility and the firmware is beta? We are installing a few EN12’s and EP2’s that could benefit from a centralised interface, and would be totally fine with a beta front end (and it just meant a few quirks and weirdness), I’m a little less brave with quirks and weirdness in firmware that effects operation as opposed to configuration (I appreciate that you can’t guarantee anything).

Would appreciate your advice! Otherwise, is there any form of roadmap or eta for the final release?

This should be released in a couple of weeks. The firmware is “beta” as well so far, although it actually fixes some bugs in the current version.

1 Like

Hi Matthias,

This is great. Some feedback below:

It would be great if you could also make changes to port and device settings directly from the CLU instead of it just opening the web GUI.

It should auto-refresh after changing a devices IP settings instead of having to do it manually. Or if it could just auto-rediscover that particular device.

Uploaded firmware to an RDM10 with no issues.

Ran into a bug with changing the device name from the CLU. It worked fine for an RDM10 but with an EN4 changing the device name in the CLU didn’t change anything at the unit. It did seem like it was saving somewhere since the new name would persist when refreshing the CLU but it never changed on the device screen. Even after power cycling the EN4 and closing and reopening the CLU program the new name persisted in the CLU but not at the device.

I’m unable to download the netron central utility, it says it can’t be found.
Is there any other website where I can grab it?


Sane here. I wonder if another version came out. Hard to find this download.

@ggm and @austin3579,

Please try using this link to the Release Candidate version 1.006

1 Like