Install Error 27503

I tryed to install Onyx on my Home-PC
And i got an error while installing:

Error 27503. Error retrieving version string from Microsoft SQL Server ‘(localdb)’.\ObsidianOnyx’. Class not registered (-2147221164)

Any ideas how i could solve this issue?

Sincerely

  • Sascha

I found when the problem occurs. I had same issue when i had installed any othe than 2012 SQLServer LocalDB. I had installed SQLServer Express 2017 with localdb support then i uninstalled LogalDB then I be able to install onyx.
I think this is the onyx bug.
I you have installed Onyx and then you install SQLServer LocalDB component you will not be able to load show.
I hope guys will fix the issue quickly because I’ve another software on my laptop which needs to have another version LocalDB

1 Like

Very late response, but sadly that doesnt help me since, even when i uninstall every SQL component, its still not installing