4.2.1045 error on startup

On my secondary computer I tried upgrading to 4.2.1045 tonight, but am getting an error on startup. (And this is why I always upgrade first on this secondary, less critical, PC and run it for at least a couple weeks before I update my primary computer.)

Dell Inspiron 7000 series laptop
Windows 10 Home (Version 1809, Build 17763.316, and windows update is fully up to date)
It has been running 4.0.1010.0, with no problems, since it was released.

After installing 4.2.1045 I get “Runtime error 217 at 056EF468” on startup:

After clicking “OK” I get “Internal error” “Onyx can’t load the “Prioritizer”. Please contact your vendor if this error occurs again”:

Tried unintalling 4.2.1045, rebooting, running cleanup tool (as Admin), rebooting, and re-installing 4.2.1045. (Several times.)
Also tried with Windows Defender and Firewall turned off.

Got those same errors every time.

After multiple attempts, and trying different things to get 4.2.1045 to work, I decided to try reverting back.
I uninstalled 4.2.1045, rebooted, ran cleanup tool (as Admin), rebooted, and re-installed 4.0.1010.0… and it startups up just fine.
(Thank goodness. At least the secondary computer can continue to run on that until I figure out this issue with 4.2.1045.)

Any help, suggestions, advice would be appreciated.

Well, I spoke to soon.

The re-install of 4.0.1010.0 is mostly okay… EXCEPT I can’t select/change any Views!

The Sidebar buttons with my views assigned to them do not respond to a left click. They do respond to a right-click however. And this is regardless of if I use the touchscreen, the laptop trackpad, or external mouse. All other sidebar buttons appear to work fine, only the ones with Views assigned to them don’t respond. And even if I try to use the Launch Views it won’t launch any of the “Views” views, but it will launch any other view - Fixture, Presets, System.

It just does nothing when I press anything that would change the workspace view.

On load of the file it does successfully load the view that was up when the file was last save. Which is good, because that was our “Operate” view that we need in order to operate the show. So at least we’re able to operate the show as usual.

But because if this I can’t get to my programming views, so it’s going to be pretty difficult to modify anything or record anything new. The Sidebar buttons that have a Popup Window work, so I guess I can put all the Windows I need for programming onto Sidebar Popup buttons until this is resolved.

In addition to the above, I got a report about another error, upon uodating from 1010, to 1045. W10 OS

Hey Team,

To add to the “list” of install issues…I’m getting an SQL Server 2012 Express SP2 LocalDB error. This is a test machine at the moment to help identify install issues for other production machines. It’s running Windows 10 Enterprise Version 1809 Build 17763.316. It is fully updated and already running 4.0.1010. Running the ONYX prerequisites are installed successfully, but it fails somewhere after that. This machine had to be remoted in to by @Matthias to get 4.0.1010 to install correctly. I believe it had one of the Common PC install problems when upgrading from M-PC to ONYX, but not positive on which one. Also, from what I can tell, the SQL Server 2012 Express SP2 LocalDB is installed. I have attached a few pictures, but also have a video of the entire attempted install process that I can share somewhere (I think) if needed.

I have not tried to revert back, in case someone needs to take a closer in depth look to help identify an installer problem.

Thanks in advance,


Next update:

I reverted to the System Restore point before the most recent Windows Updates (which installed on my laptop on 2/12). Which reverted my laptop to prior to these updates:

I uninstalled Onyx 4.0.1010.0, ran the cleanup utility, and re-installed Onyx 4.0.1010.0 (rebooting after each step).

Now my View buttons (and everything else) are working again!! Yea!

Tomorrow I will attempt to install 4.2.1045 again, this time now with my PC reverted prior to those three most recent windows updates. (My wifi is off on this PC, so it won’t re-install those updates yet.)

So I installed 4.2.1045 on my PC, which I had reverted to before the most recent Windows updates, and Onyx started up just fine. I did not get the error I was getting before. Just doing a few quick things in Onyx it appears to be behaving properly, including switching Views is working!

The System >> About Window now shows I’m on: Windows 10 Version 1809 Build 17763.253

So it looks like maybe one of those 3 Windows updates maybe caused my issue.

I guess the next step is to install those updates and see if it affects Onyx 4.2.1045 when its already installed.

Just a note: I didn’t think about this, but when I reverted to the System Restore point my original Onyx 4.2.1045 downloaded install file was gone. Therefore I had to re-download the install file for this install (which I did on another computer, so I could leave the PC disconnected from the Internet.) So I suppose it’s also possible that my original downloaded install file was bad/corrupted, and this new one was good. But I would think that the issue would have been on the install if the install file was corrupted, yet my issue was on startup not install, so I think the original install file was fine.

Onyx 4.2.1045 started up and appears to be working just fine after installing those latest Windows updates on top of it.

So Windows is up to date again, on Version 1809 Build 17763.316, and Onxy 4.2.1045 appears to be working.

(If I feel ambitious tonight I might uninstall and clean Onyx, and re-install it again to see if it still works or if I get the issue I got before.)

Well, I uninstalled and cleaned Onyx and then re-installed it (on Windows Version 1809 Build 17763.316) just like I originally did. But this time it had no problem on startup.

Hmm. So whatever the issue was, it looks like somewhere in this whole process it was completely cleared up.

Oh well. I’m happy, since it’s working for me now (and Windows is up to date).

Hope this thread of my ordeal helps someone with theirs.

Update for my install issues…

I also uninstalled ONYX 4.0.1010. At first I went through the “uninstall apps” of windows settings. From there I uninstalled all ONYX related apps. There was three…ONYX, Obsidian Driver Package, and a third I can’t remember the exact name. As I was scrolling, and after I had already uninstalled ONYX, I found a rogue M-Series app with 3.71.xxx. So I uninstalled that also.

Now this machine had the 3.71.xxx beta on it for awhile, but I thought we had removed it when we installed 4.0.1010 (with the remote help of @Matthias) as this was before the realization that the preview was causing problems. So after uninstalling all these. I restarted. I then downloaded and Ran as Admin the OnyxCleanV1 (as found on the website next to “use this tool for removing 3.71.xxx). After running the tool, I again restarted. Next I ran the Full 4.2.1045 install file as Admin and all is well.

So, I’m now also happy and everything appears to be working. More in depth testing to come, but at the moment running ONYX Version 4.2.1045 on Windows 10 Enterprise Version 1809 Build 17763.316.

And like @JoelD, I hope this helps others with any issues they may be experiencing.


1 Like

Today I had the same issue on a fully patched Win10 Pro mashine (Version 1809).
It turned out that there were two instances of SQL Express installed.
One was a SQL Express 2014 and the second was the SQL Express 2012 that the ONYX Prequisits brings along.
So it seems the ONYX installer has an issue with multiple instances of SQL Express installed.

After uninstalling everything related to SQL Express 2014, ONYX V4.2.1045 installed without a problem.