4.6 Maintenance Build 1219

This maintenance build fixes reported issues of the 4.6.1218 Version.

It requires OS 4.6 on a console first.

4.6.1219 (03/09/2021)


Added F-Key assignable Action for “RENAME” command

Added F-Key assignable Playback Control for “Playback Fader Swap” (1-10 <-> 11-20)

Fixed cue macros (including SET CL VALUE, MIDI notes) not working

Fixed loss of preset value for last logical channel after show file upgrade (typically visible in defaults preset): consider loading your pre-4.6 show again!

Fixed lack of feedback while enabling DyLOS support and adding zones to a new show due to missing 2D page

Fixed installer aborting due to IIS installation (which triggers installation of RDM report pages)

Fixed index shift for OSC playback controls

Fixed missing options due to duplicate names in direct access to parameter

Improved Web control sizing (like Art-Net node management)

Scroll wheel can now also be used for personalities in the fixture type library browser

DyLOS mapping reliability improvements

1 Like

Thanx for rename. = )

Hi Team,

The latest version is looking great. I however came across a strange little bug.

After installing this latest maintenance fix on 2/3 machines I did it to I got this error on start-up

Startup Problem

and then on one machine during the first start of the I got as far as this :-1:

I tried several times to restart the computer and then reload the software but for 4 or 5 times it keep saying another version was still running.

I eventually turn both PC’s off completely and left them for 5 minutes and then restarted them and they both worked fine. It seems like that during a restart there is something being left over in the ram that is causing that to happen.

Looking forward to testing and playing with the latest version.

Keep up the good work and many thanks for the updates.

Kind regards


Hi to all!
Latest version 4.6.1219 when creating a brand new show there are some little issues:
Looking like Missing DEFORMATIONS
Looking like Missing GENERATORS
But if you re start the show they appear!

1 Like

Thanks Gian-carlo! The reload workaround works perfectly!

Is anybody having issue with the maximize zoom feature of the 2d plan?

When hitting this function, the 2d plan is not automatically zoomed in, it stays with a far away zoom level.

I have an issue with a full new show (no cuelist, default preset not changed) and result in 2D plan.

Patch following fixture:


Add a Dylos zone around the bar, and play the media 35 from folder 3 Monochrome:

As result, the 1st, 3rd and 4th bar are correctly doing a full black and white chase, while the 2nd bar as its 6th pixel (top to bottom) which is Magenta:

This also happen with fixed picture (like Elation Gobo). Instead to output RGBW at 100% on this pixel, we have all at 100% except the green (which explains this light magenta):

As workaround, I have moved the LED Bar in the 2D Plan, and it has fixed this pixel trouble

Correct, we noticed as well but the fix didn’t make it for this build, will be included in a next one. Restarting the software fills/shows them indeed.

In this version of Onyx 4.6.1219 when we patch a “fixture” as" info", why don’t you let us know for witch firmware version it’s related to? This can cause a lot of issues and a very bad day “tried this on my show”,so during the patch we can verify the “firmware version” ,we can check it ,and fix it rapidly.Otherwise troubles would come along without the correct version.

Something strange in" 3 preset mode", but if I have used the 2 preset mode and then change idea and select “3 preset mode” . One of the presets or "preset1 or 2 " looses the original preset information that was originaly selected preset ! so I need to go again thru all of the 3 presets and check if all is ok and correctly selected!

HI to all!
Please Can you explain this to me maybe it’s a little issue or not, just to know if the behaviour is correct!

After continuing working on my new showfile, I saw that Dylos was not working properly at PC restart.

The media was playing, but nothin was happening to the fixture in the Dylos zone. To fix it, I have moved the Dylos zone in the 2D plan, and then it has start to work back.

It smells like something related to the last issue I’ve reported about pixel not having the same color than others?

Could you send (PM) us that show file, so we can have a look? Preferably the version that doesn’t map to the fixtures at startup, before you moved the zone around (so we could have a look at both issues hopefully)

Hi to all Using Dylos 3 preset mode:
I have noticed that if I use dylos in 3 preset mode let’s say 3 different “positions” and set a smooth speed all works fine! but if you change one of these presets like I did in my case “preset 2”, and insert there a zoom preset ,what happens is that the pan tilit ones preset 1 and 3 loose the smoottheness of movement. Just to make an example they look like scanners going faster than the original speed ,even if nothing has been changed on the original speed!

Thanx! = )

The fixtures lost a pan tilt step from preset 2 , so wouldnt they need to travel from preset 1 to 3 and thats black to white so its a lot stronger change = faster movement or even jumps?

Yes absolutly right didn’t reflect on that!

When editing with this feature ,please show us" active non active" or otherwise make this an automatic selection of all fixtures in the current edited cue! = )

Hello Folks,
since i have updated to version 4.6 i can’t use my user fixtures anymore. Is there a way to convert them into the new fixture format? I mean it is nice to have this new library but if I have to build them all new, this will be a lot of work. :sleepy: :roll_eyes:
Greets Maxi :smiley:

Please explain, how can you not use them?

I can’t import the old user fixture

This means the fixture was build in way that is not supported. We added a lot of rules to enforce certain standards.
Request the fixture instead if needed.

When selecting a Group or Fixture I am experiencing a significant delay before the Presets associated with those fixtures are indicated and a Preset can be selected. Plus… the Clear button does not light after the fixture selections - only after then changing an attribute (selecting a Preset).

My videos show me selecting from the 2D Plan, but it also happens when selecting from the Fixture Center.

It occurs both on my show computer (Intel NUC8i7HVK, 8th gen Core i7, 16GB Mem, 256GB PCIe M.2 SSD, Windows 10 Pro) and my testing laptop (Dell Inspiron 7737, 4th gen Core i7, 16GB Mem, 240GB SATA SSD, Windows 10 Home).

Occurs in 1218 and 1219.

I’m wondering if this is a bug, or if this is some kind of corruption with my show file.

I’ve uploaded several videos showing the issue to my YouTube: Onyx Fixture Selection Delay (4.6 - 1218 and 1219) - YouTube