Art-Net problems with Botex / Showtec Node 8 Pro - workaround using Chamsys MagicQ PC

So I’ve been searching for a fix to this problem for more than half a year and I think this problem might occur with other Art-Net devices as well. I will first provide you with a short summary of the problem, then give the suggestion and finally I will sketch the whole picture and the workaround I figured out by combining Chamsys’ MagicQ software with the sACN output of Onyx.

I have been very frustrated with this problem, so hopefully 1. this problem will be fixed in the future and 2. someone with similar problems finds this topic, to create understanding of the problem + help you with the workaround.

I bought a Showtec Node 8 Pro (8 universes Art-Net node) about half a year ago, but even though the device is fully detected by Onyx and addressable (I can only use 4 universes, since I only own the M-Touch), the Art-Net node’s 250k speed indicator keeps flashing on-off about every second and all DMX devices connected are acting crazy! I’ve tried force unicasting to the node, adjusting the timings, playing with the IP addressing and more, but nothing helped.

Today I finally found a workaround and the nature of this workaround indicates what the problem seems to be with the software of Onyx and how to fix it.

Please add an option to select the Art-Net communication mode, similar to the Chamsys’ MagicQ PC ‘Reduced Output Rate’ feature. It seems Onyx is using a ‘Mixed + Changes only’ DMX output rate variant, which does not play well with this Art-Net node (might impact nodes of other makes too). Additionally please provide a ‘Continuous’ DMX output mode, to fix this problem. This works absolutely fantastic with the Chamsys software.

Full specs and story (solution below)
Alright, my set-up is an HP Elitebook with an i7 7600U CPU, 16GB of RAM and a 256GB SSD. I own a M-Touch and an Entec dongle, as well as several MIDI controllers like the Behringer X-Touch Compact, 2 Icon i-stages. Additionally I get the job done with 2x 17" ELO touch screens, connected by a D-Lock DP splitter and a programmable keyboard, mounted into 2 slant flightcases.

Since I was running out of DMX channels and wanted an easy way to expand universes without adding much extra copper and more expandability options in the future, I opted to buy a Showtec Node 8 Pro, which I mounted in a 3U rack case with two additional DMX repeaters. Weirdly enough, I could not get a single universe working properly/reliably.

My physical setting on the node:
Sub-net: 0, Universe: 0
Enabled mode: Art-Net (not CL 100II) and Break (not Last Hold)
IP Address:

I directly connected the node to the Ethernet port of my laptop, which I addressed with

Onyx detected the node effortlessly in the EtherDMX menu with IP addresses and (auto generated).
It also instantly configured universes 1-4 to and 5*-8* to (stars indicating that these are locked universes).

I opened the Art-Net tab next, in order to enable the casting option. After fiddling around a bit with the settings, it became apparent that the device played best with Onyx in unicast mode.

Eventhough everything seemed to be set up correctly, my data LEDs and 250k speed LED indicators on the node kept flashing on-off about every second and the repeaters followed the same pattern. Only when parameters changed in Onyx, the 250k indicators would light up more frequently. Meanwhile the DMX output would be totally crazy. Devices moving all over the place, random strobes and color changes in all devices connected to the node.

I COULD NOT GET IT TO WORK. No way I could run shows with this random behavior.

I searched for hours and hours over the span of half a year, trying to find a solution and I found some forum posts suggesting that this node would always need two Art-Net streams to fill all 8 universes. I started to search for other (free) lighting controller software that could ‘fill in the gap’ of universe 5-8. I tried several small-name brand packages, and tried both the PC software from Avolites and Chamsys.

Partly by coincidence Chamsys MagicQ PC could provide a solution, but without ‘filling up’ the other 4 universes, because that proved not to be the problem. The output rate proved to be the problem.

I installed MagicQ (never used it before) and after some digging, I found a working solution by connecting the sACN output of Onyx to the Art-Net output of MagicQ by merging the DMX universes.

    • First we set-up the MagicQ software to work properly with the node - -
      Run the MagicQ software and choose to run the Simple generic console (runs in DEMO mode).

Click on MaxiWing in the Panel menu.

Next go to Setup > General.

Open the Network tab and make sure the IP address is set to the static IP address we set earlier. This will prevent Art-Net output problems later on. Also set Art-Net type to V4 Unicast, to improve Art-Net performance later on.

Open the View DMX I/O screen en set everything up as in the screenshot below.
Make sure universe 1-4 are enabled, that the Out type is Art-Net, that the In type is sACN and that Test is set to Merge.

Next open View Settings again and open the Hardware tab.

You will find that the Reduced Rate Output is set to ‘Mixed + Changes only’. As long as this mode is set, the node (mis)behaves exactly the same as when it’s directly communicating to the node from within Onyx. Only when you change this mode to ‘Continuous’, suddenly the node and it’s connected devices start to work as intended.
So, update image
To image

    • Lastly we pass the DMX output from Onyx through to MagicQ - -
      Start Onyx and open the settings menu. Under Network, click Settings, Enable sACN on the local Ethernet adapter and click Apply.

Next open the EtherDMX menu and click the Art-Net menu. Make sure that all Art-Net is FULLY DISABLED.

Lastly open up the sACN tab, enable streaming on universes 1-4, enable sACN on the local Ethernet adapter and click Apply.

THAT’S IT! You should finally be able to use this node no problem with your devices.

Additionally I checked how much impact this step-in-between had on my system resources. When I was outputting 2 universes with constantly changing parameters, Onyx would use up to 20% of my CPU resources, while MagicQ (who was relaying the DMX data), had a max use of 2%. It mostly sat under 1% usage, so no major impact on the system!

It is not the nicest solution, but hey it works and I did not have to invest in additional hardware or software.

Hope it helps you in any way.

If you have any questions regarding this topic, I would like to hear from you.

Kind regards,
Daan Groen
Daan Groen Productions