Hello Hive Mind !
I have picked up an interesting using an EP4 on ONYX software on a PC (4.8.1244.0), I am using 20 x Martin VDO Sceptrons in DMX segment mode , to Address the fixture I need to RDM the units and i am using an EP4 to breakout DMX to the Lines.

I am using port 1 and 2 on the Node for the DMX to the Sceptrons so initially when i connected the node (brand new) and I did an RDM Scan all 20 of the fixtures discovered and I could set the DMX Addresses however in my patch the Sceptrons are on Universe 3 so I went on the webpage of the node and changed port 1 and 2 both to universe 3 but when i rescanned only 7 of the 20 “showed up” on uni 3 but i couldn’t access their settings or change address and the other 13 was divided between uni 1 and 2.

After a few Repeated scans all of the fixtures showed up on uni 3 but still not able to adjust addresses or settings, Cycling the node does nothing and reverting the settings also does nothing the only fix that works if i factory reset the node. I also tried firmware on the node and an older EN4 node same scenario, well i even tried an Luminex node and it also did the same . the Problem seems to be RDM from ONYX because there is nothing wrong with the DMX output on the nodes that seems to work just perfectly.

Has this Happened to anybody else?

Hello Bart!

Yes, it seems RDM is not well implemented on Onyx.

I’ve done many tests with an EP4 and also with nodes from other manufacturers and found that Onyx ignores most of the packets from nodes with RDM devices update (ArtTOD).