automatically generated IP addresses are so drastically different

(I have much more to learn about Artnet and calculating IP addresses that work with artnet in general.)

When I don’t use the automatically generated IP addresses for EtherDMX the XNet doesn’t see each other, so joining shows doesn’t seem to work. But when I do they are all so drastically different from each other. My router only allows editing of the last two decimal points. So using TouchOSC isn’t an option when the IP address is so drastically different.

Feature request: to have the option to limit the net mask to two decimal places on automatically generated EtherDMX addresses, e.g., 255.255.0.0

For example, I started with an automatically generated IP address in the EN4 and set my router to that IP address range. Telling Onyx to automatically choose IP address on both PC’s allows them to see each other on X-Net and the Artnet works. But then TouchOSC won’t respond because of being out of range with the default gateway. The second decimal place doesn’t match with the gateway of the router.

The auto-generated IP address from the EN4 is: 2.205.71.101

So I set the router to: 2.205.71.1

The automatically generated IP address in one Onyx PC is: 2.156.46.12

The generated IP address in the other computer is: 2.216.164.1

So these generated IP addresses bear no relation to each other, other than 2. And they don’t seem to query the IP address of the router before auto generating IP addresses. Why don’t they ping the router to find out the router IP and then generate IP addresses based upon that?

If one were to choose an IP address manually, oneself, then how would one do it? Because I’ve tried a few times and X-Net doesn’t seem to work when I do.

The automatic 2.x.x.x address is a system from the Art-Net protocol and we have to stick to the rules they made.
Use DHCP from the router and have the router handle the addressed instead.

When I do that the EN4 artnet connection doesn’t show. I have to manually override the IP address.

Maybe it’s superstition but I think I’ve had better luck maintaining the X-net joined shows connection with the EtherDMX generated IP addresses.

what is the address / subnet on EN4 and ONYX that does not work?

what version of ONYX?

Perhaps a clarification. It works but the EN4 isn’t visible in Onyx software when I use automatic DHCP. But if I use EtherDMX then the four universes of Artnet becomes visible. They show up.

Using the latest version .38

And now updated to .39
Inhibitor and Overrides problems after updating show file. Tried reloading show file. Tried resaving the Inhibitive fader. Will report later.

@mgerardi could you assist here?

@truthcollins,

I’ll try to check our basic youth room setup for confirmation (now that we have a firmware 2.92) but I have an NX1 directly connected to an EN4 and I was almost certain it shows in the device section with the ports. Just using a basic “automatically assigned 182.168.x.y” IP for both the NX1 and ehe EN4. It is running sACN. No DHCP (as it’s direct).

In your system, example I’m wondering if your issues is with the subnet. All those Automatic IPs should work, if the subnet is wide open (255.0.0.0). I noticed you mentioned a 255.255.0.0.

With that said, I also have a larger system that we run sACN on with a dedicated VLAN for the control protocol and another VLAN for the ONYX remote and X-Net. Most of the units on this system I have set to static IPs and I track what gear has what IP as we add it. I’ll see if I can get something to show on it later in the week, as I’d like to add more NETRON to this system.

Hope this information gives you some ideas and things to try.

Watson