Cannot select DMX ports on web interface after updating to v2.4 on EN12

I was experiencing the unit completely locking up - no local control, no web control, no dmx passthrough - so I updated to v 2.4. I no longer experience the lock up, but I cannot select the DMX port to configure on the DMX port configuration screen. There used to be a row of boxes 1-12 to select which port you want to configure. That area is now blank. Tried chrome and safari on different machines.
I updated both the Firmware and web version to 2.4.
Bootware VersionV1.0
Firmware VersionV2.4
Web VersionV2.4

I’ve seen these missing parts with some antivirus systems like Avast.
Also reset the EN12 to factory defaults from the front panel.

Sorry to necro a 20d old thread, but I’m seeing the same issues and do not have Avast or any other antivirus on my pc. I even disabled windows firewall.

I’m seeing the same issue on EN4, EN12, RDM10.
After a factory reset, the display is there to select ports, but then it goes away.
To add to it, if you go to the ‘home’ page (click Netron logo), the info changes to say EN4 and the table below is gone.
(it shows EN4 on every device, even though prior to changing DMX ports it would show the proper device type)
Also, I tried the Netron Presets option, ArtNet 2.x.x.x Start Universe 5, it accepts it, but the Home page again changes to be EN4.

Having to go to the device and setup complex port routing etc is rather frustrating, some of my units are in attic spaces not easily accessible…

I still have the issue. Avast is not a factor for me at all either. I haven’t tried a reset yet because I haven’t had the time to concentrate on it when the facility hasn’t been in use. I have done a reset one other time and the config restore file I saved just prior didn’t work, so I’m nervous that will happen again and I want to make sure I have enough time available to rebuild config from scratch.

Tried a local hardline connection to push firmware update, just in case.
Same issue.
Changing DMX port output assignments LOCALLY at the device - Same issue results in the interface.

in fact my EN4 won’t update properly at all, has no web interface beyond the hidden /update.html file, and gets stuck at 12% in the onboard screen. (then the webpage times out and i have to start over)

Not sure where v2.4 has gone wrong here, but I’ve got 5 devices and can’t setup my routing on any of them.

Email us your contact info to and I’ll be happy to call you.
Where are you located?

Hey Mathias,
Thanks for the reply!
So I emailed prior to catching your response. (The tech number I called earlier was Elation, so that’s the email they gave out)
Happy to fwd it along if that won’t get confusing?
I’m in Portland OR.

Minor update- I played around with my EN4 (v1.6)further this evening, and I’m not seeing the same issues in 2.2
Each time I try to push 2.4, though, the update fails.

use the obsidian email, I do not have access to the other one. I’ll be happy to call.

Done! Thank you , as always Obsidian support is fantastic because of people like you!