Can't connect USB anymore NX WING

School lightinig board, functionnal in June. Unplugged all summer…
When trying to connect to PC - Connect, then disconnect… on and off non stop. Light LAST flashing, and FIRST fader flashing / Then lights over connectors on right side flashing.

Maybe weird but plugged on a dedicated computer not linked to Internet, no changes, no updates…

Nothing works !

What version of ONYX are you running?


This might not be the answer you want to hear. But that is a fairly old version. And if your Windows computer has been doing Security updates then this is probably the cause. I would suggest checking and updating windows, restart and check for windows updates again (restart if there are any left) and then install the current version of ONYX.

BUT there are some things you need to be aware of before you do that.

  1. You’ll want to make a backup of any showfiles you want to keep just as a precaution. Being on a PC won’t wipe the drive like a console, but it’s still a good practice.
  2. There has been a library overall between the version you are on and going to. Everything should still work, but you’ll have to "Exchange your fixtures to the new library format at some point (sooner than later).
  3. You’ll also need to update the DMX output cards firmware for the NX-Wing as version 4.8 made some improvements in that area (this is a secondary issue and not related to the current connectivity problem you are having).
  4. There was a license change that reduced the number of free universe from 4 back to 1. This won’t really affect you since you have an NX-Wing (64 universe), but just one of the major changes when coming from an older (4.4) version.

All of these things to be aware of is really just to make you aware of things to check. Please don’t let that be a reason to keep you from updating (although that’s probably what will solve your problems). Also, the additional features, function ability, and improvements made will by far out weight staying on an older software version.

Hope this helps,


I’m French, I’ll read with attention and try.

But before I do, just want to remind that the computer used for it is not connected to Internet - meaning there was no changes of software, no update, no security update… (windows nor Onyx), therefore, nothing should have changed… I chosed that in the begining supposing “It works, lets keep it that way” :slight_smile:

Also, I remember that USB disconnected once in a while last year (maybe 5 to 10 times) wich is not a lot as it’s use on a daily basis. Happy solution then was to close NX-WING and restart ONYX.

Could there be a hardware problem with the USB itself ?

Also, I tryed with 4.8.1237.0 on another newer up to date computer…

Issues with specific hardware are going to need support from ONYX directly. If no updates, that is good (should be solid) bad, as you can’t get new features. ONYX has a software application and a driver package, that gets updated with every couple of versions. It’s possible when you tested on 4.8 that it tried to update something (this is way beyond my knowledge).

That said, I have an NX-K and a loose USB port on one of our machines. It will connect and disconnect several times (as you have described) and the NX-K will not work. I simply go to the firmware update tool in ONYX and re-install the firmware for the NX-K and then it works and responds. Maybe try that. You can also check to see if Windows is seeing the USB device in the windows settings to make sure you have USB connectivity.

I have an M-Touch and I’ve responded about this issue in the Onxy users Facebook group.

One factor is USB power settings found in Device Manager HID and USB hub settings. Basically, find the USB devices & hubs and uncheck the power saving setting. Also power plan selective suspend.

It used to be if this happened I could disconnect and reconnect the USB and it worked again. Now Onyx has to be restarted before it works again.

Having made every effort to stop Windows 11 from turning off the USB devices I’m using, it happened again to me last night.

Please, Onyx developers, make it so that we can simply disconnect and reconnect the USB cable to get it working again.

I have tryed everything proposed here… updates, power control for USB, try different computers and wires… It’s most probably hardware problem.

Where can I repair the board (2 yo bord :frowning: )

I’m in Montreal, canada

@FelixLeclerc -

The NX-Wing has an external power supply so the USB power settings shouldn’t affect the operation like it can in the NX-Touch. However, going to sleep can be a connectivity issue (which you said you already checked).

Do you see the devices in windows settings? This would be a way to help troubleshoot. Something like this picture?

At this point in the process I would suggest either calling or emailing support and get an Official Support request started. They can help identify what might be going on and who best to repair (or maybe ship to them). This definitely isn’t the norm. I’ve always had great success and been pleased with the help from support. I’m sorry that this is happening to you on a 2 year old board. But I would reach out right away. I can’t remember for sure but there might be a two year warranty on consoles.

Here is the support request and a dealer locator… ONYX Software Support Requests (

Hope this helps,


Definitely sounds like a hardware issue, please contact your supplier for repair