Cherry PIE POS Keyboard Issues

I am having some issues programming a Cherry Pie POS keyboard. Most things are working fine, except for the some issues I am having which I will list below. I believe these are a combination of bugs and documentation needing to be updated.

For instance;


When using the numberpad on the console it’s easier to program faster when you have the tactile response of actual hard keys, vis a vis, a programmable keyboard. Since the numbers aren’t listed in the Help Manual (which I posted a picture of below), it is assumed that you just use the side numberpad on your keyboard if you have one.

The problem is it works fine for groups and fixtures (selecting, copying, moving etc), but NOT for “Cue” or “Load”

I’ll give some examples of what keyboard shortcuts work and don’t work in regards to “Cue” and “Load”

~Copy > 15 (when you type in a number after Copy or Edit, it automatically takes ‘CUE’) > @ > 16 > ENTER [THIS WORKS]

~Copy > CUE > 15 > @ > 16 > ENTER [THIS DOES NOT WORK as it won’t register that initial 15]

This is where it gets tricky, because if I enter that initial 1 (of cue 15) on screen via the digital command pad, after that any number on the physical keypad will work fine; Therefore

~Copy > CUE > 15 (Hit 1 on screen, hit 5 on keyboard) > @ > 16 > ENTER [THIS WORKS]

~These SAME Rules apply to LOAD as well. In order to punch them in on the keyboard after pressing Load/Cue (excluding when it automatically selects CUE in the first instance I listed above) I HAVE to hit the first number on-screen, and after that a keyboard will work.

Someone even reported this bug way back in 2016, but it must’ve slipped through the cracks…/1453

  1. ENTER;

In the help manual, it states in order to hit Enter, you have to press CTRL + ENTER on the keyboard. This is simply not the case. I tried it on 2 different computers, with 3 different keyboards, including the windows on-screen keyboard. I believe the manual has to be updated to reflect that only the ENTER key on a keyboard will work. Should be pretty self explanatory that Enter is Enter, but the manual is incorrect.

  1. Dot or Period, /, - & +

Same issue as above. The Period on the keyboard is what works, while the manual states incorrectly that it is CTRL + >.
Same goes for the Backslash, the - & the +

All of those should just be listed as the actual key, and not CTRL + Whatever


Is there an update to this bug, as it still doesn’t appear to have been fixed.