Custom fixture colours not working correctly in 2D Plan. Worked all ok yesterday

2D Plan was working correctly yesterday with a custom fixture. Today RED channel displays ok, however, GREEN and BLUE channels display only as black. A connected fixture works all ok and DMX I/O window is also correct, so no changes there.

I wonder if the issue is to do with the “Unassigned channel(s) detected” pop up following today’s PC restart and and me not really understanding what that pop-up window is about. Is there any documentation for this? My confusion with the “Unassigned channel(s) detected” window is

  1. I’ve already completed all the channel assignments in the Fixture Editor, so what’s the reason for "Unassigned channel(s) detected? Here’s the window:

  2. When I move the unassigned channels from the left section to the centre section, is the numeric order important? If so, what do I do with channels unrelated to the currently problematic fixture?

A new Show File with the custom fixture profile imported works all ok.

Any ideas gladly accepted!

… well I’m mystified!

It’s a new day and on firing up Onyx there’s no sign of the “Unassigned channel(s) detected” window and 2D Plan is working all ok again !

I can’t figure out what’s changed but hey, everything’s working, so I’ll take that as a win!

… and today the issue is back!

Looks like the fixture channels are getting assigned to incorrect colour channel faders in the main showfile (depending on goodness knows what) on startup.

The incorrect mapping I’m currently seeing is:
Fixture RED channel - correctly mapped to RED channel fader
Fixture GREEN channel - incorrectly mapped to GREEN BOTTOM THIRD channel fader
Fixture BLUE channel - incorrectly mapped to BLUE BOTTOM THIRD channel fader

A test showfile is all ok (of course!)

Ok, so the fix appears to be:

  1. Onyx > Menu > Load/save > Workspaces and Save the Workspace settings

  2. Onyx > Menu > Load/save > Settings and Reset to factory defaults - this triggers the “Unassigned Channels Detected” window. Assign colours to colour tab in correct order (again - why are the settings from the fixture not honoured?)

  3. Restart Onyx and restore the Workspace ← It’s the restart of Onyx that does the trick