Elo Touch Input Issues

Digging through the forums and I’ve seen a couple topics similar to this with no resolution.

I have an Elo 1900L that I’m trying to use as a second monitor for an NX1. When I touch an item on the Elo, the action is actually performed on the NX1 internal screen. In other words, the touch input of the Elo is being used on the internal screen.

I’ve tried the “identify touchscreens” and “calibrate touchscreens” tools, to no avail. I tried using this screen for an Avolites Tiger Touch II and had the same issue, so now I’m wondering if it’s a driver issue.

Elo has a driver package online, but there doesn’t seem to be any tool for installing driver packages on the NX1. Under “diagnostics” there is a USB device viewer where I can see the Elo screen, but no option to update the drivers.

Any guidance would be greatly appreciated.

Elo support was removed a couple versions ago. For the reason you have found. They require a driver and not the generic windows touch screen support. Our Elo touchscreen also preformed as you described. We ended up replacing it with the Dell P2418HT.

This is for the consoles (and my guess similar for the Avo). That said, if you are using a PC, and can install the Elo driver package, you should still be able to use the Elo.

Hope this helps,


Ah, I saw an excerpt from the release notes for 4.6.x that mentioned the end of “custom driver support” for Elo. Guess I should’ve put two and two together.

Thanks for the response.