Error 1720 when installing Onyx 4.0.1010

Error 1720 when installing on Windows 10 build 1809. (fresh installed windows 10)
Windows is up-to-date.

PreInstall installs correctly

installer stops when loading default show file.


can someone help me?

Full error message from EventViewer

Product: Onyx – Error 1720.There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor. Custom action LoadDefaultShowFile script error -2146827859, Microsoft VBScript runtime error: ActiveX component can’t create object: ‘ShowLogic.ShowManagement’ Line 41, Column 3,

Disable HP Hotkey UWP Service + restart COM+ Event System.

1 Like

Hey @robin.pestman!

You’ll find the resources and fixes for that here.

//Martin Hedström

Check this reply:

Ok i’m going to have a winge here. The ONYX installer the way I see it is broken. I have run the installer on three different machines that have never had Martin M-PC or ONYX installed. That is clean machines each one failed when attempting to access the localdb with error 1722 request to sql server timed out.

The fact this happens on three clean machine concerns me, as the M-PC installers always worked fine.

In my opinion the installer is broken and Elation need to fix it!.

Can you try to install the last release version of M-PC on one of these?

Same here although I’m getting Error 1720 as well as Error 27502… need a hand here. I myself cant return to last version, old version was on older laptop that motherboard fried.

Sorry the Disable HP Hotkey UWP Service + Restart Com + Event System is a no go .

Does not work.

hello Bar,

i guess i still have v3.44.604.0 setup files for M-pc i you need it

What system do you use?

Hi Kristiensen… I happened to follow the instructions and did a complete clean in order to upgrade to Onyx for the latest fixture files.Unfortunate for me it did just that M-PC cant be reloaded,
have an error there and Onyx still won’t Load.
My computer is an HP and so far from what i gather it works directly on Dell and Lenovo. hopefully i can find the fix soon.

Hello Robin…Ive replied directly, but just in case this is my operating system ;
System Model HP ZBook 17 G3
System Type x64-based PC
Processor Intel® Core™ i7-6700HQ CPU @ 2.60GHz, 2592 Mhz, 4 Core(s), 8 Logical Processor(s)
BIOS Version/Date HP N81 Ver. 01.33, 2018-07-17
SMBIOS Version 2.7
OS Name Microsoft Windows 10 Pro
Version 10.0.17134 Build 17134

does this help ?

To take away error 1720 find here, on the forum file “FixCOM Dolby_Realtek.reg” and run it and allow it to add those entries to your registry. Next run “Component services” addin in control panel (for me it is easier, to run admin commandline there type “mmc” and there add the “Component services” addin, sorry, cannot give you exact solution - I’m using localized Russian Windows). Next open in the left pane folder something like “COM+ Applications”, click one by one it’s subfolders (only 1 level depth, not deeper), then click next folder “DCOM Settings”, in my case it offered to build the contents inside.

To fix the 27502:
Try the following:

  1. start commandline app as administrator user (in different Windows versions it is done different ways, also depending on your UAC state), in common case you need to find cmd.exe and start it with the right mouse-button “As Administrator”
  2. In that commandline window, type:

sqllocaldb info

(for more clarity I’ll write in CAPS first word SQLLOCALDB)
you have to get something like this:


If one of those missing, you need to create it by hand, do the following - type in the forementioned commandline window (for example you want to create ObsidianOnyx database, actually, what I needed to do to overcome 27502 error):

sqllocaldb create “ObsidianOnyx” -S

That must help.

I create a new user and download the software,its worked…

Thanks Alex we are good to go.