Error When installing Onyx 27502

I’m getting this error when installing Onyx, it hasn’t been installed on this pc before.
I don’t really want to fully re install windows.

Any ideas on what i can do to fix it?




have tried Clean up Onyx and remove all files containing MartinController.

Still no joy.

I’ve got the same problem and cant’t find a solution.


I have just come this same error while trying to reinstall V4.2.1039 on a Windows 7 X64 system.

Any ideas how to fix this problem don’t really want to have reinstall the OS again.



Have you tried Release Candidate 4.2.1039? They fixed some installation issues in it.

i have the some error with old onyx also this new install in 2 computer windows 10 and windows 7 all is updated

Hi. I’m trying to install 4.2.1045 but I’m getting the 27502 Windows error. I’m running Win 10 and tried running the cleaner to no avail. Any thoughts?

Try the following:

  1. start commandline app as administrator user (in different Windows versions it is done different ways, also depending on your UAC state), in common case you need to find cmd.exe and start it with the right mouse-button “As Administrator”
  2. In that commandline window, type:

sqllocaldb info

(for more clarity I’ll write in CAPS first word SQLLOCALDB)
you have to get something like this:


If one of those missing, you need to create it by hand, do the following - type in the forementioned commandline window (for example you want to create ObsidianOnyx database, actually, what I needed to do to overcome 27502 error):

sqllocaldb create “ObsidianOnyx” -S

That’s it!

P.S.: Actually, this is some mistake in createobsidiancontrolsystemslocaldb.js script inside the installer, making it do the wrong stuff on some systems (I get it on Windows 7 SP1 x64). If somebody Obsidian stuff reading it, correct it, please, or let’s try to debug it together.

Thanks for the suggestion. I did discover that the “ObsidianControlSystems” db wasn’t there and successfully corrected that. However, I still get the same error. BTW the error refers to the ObsidianOnyx db not the ObsidianControlSystems db. I did try rebooting and reconfirmed that both dbs are now there. I’ve been able to successfully install on another PC (less robust hardware than the one I’m having trouble with). So it appears that even though the db is there, for some reason the install is timing out trying to connect to it.

So, try other ways, which I also tried, while making attempts to install, but I thught its insufficient: create administrative user with the name OnyxUser, and create 2 more databases, so that your sqllocaldb info list like this:


This sounds like user access rights issues. Possibly blocked by an eager antivirus like norton or avast.