Flash buttons not releasing anymore while pressed at the same time (DyLOS beta 1183)


I’m using ONYX (and M-PC before) for 3 years now at school & at home for training in the hope to play at some gigs.

I wrote an AutoHotKey script to use my keyboard as a touchscreen, it worked great so far.
The script is pretty simple :
I press a key -> it triggers a click to some coordinates (via the “controlclick” command) I release a key -> it send a mouse up event

Today I tried the latest DyLOS beta, and I found this :

(let’s say “A” key triggers flash button “1”, and “B” flash button 2)

Beta 4.3.1183
Press “A” then Release “A” ==> Flash “1” is released : OK
Press “A” then Press “B” then release “B” then release “A” ==> Flash “1” is still ON
Press “A” then Press “B” then release “A” then release “B” ==> Flash “1”&“2” are still ON
Pres “A” & “B” at the same time ==> Flash “1”&“2” are still ON

Release 4.2.1057
Press “A” then Release “A” ==> No problem
Press “A” then Press “B” then release “B” then release “A” ==> No problem
Press “A” then Press “B” then release “A” then release “B” ==> No problem
Pres “A” & “B” at the same time ==> No problem

So I don’t know if it’s something known, I haven’t found anything about it so I created this topic. What I’m sure is that it’s a regression from the release version where it works great as I explain, I know my use case is pretty special but I guess users with touchscreens are experiencing it too?

Thanks in advance for your help & if you need more details let me know!


EDIT1 : Tested in 1883 and the bug is still there

Please try 1183 and report back.

1 Like

Thanks for your quick reply @Matthias.

I tried 1183 and the bug I described above is still there, I will edit my original post.

Hello, (multi-)touch support has been a complex topic, especially to support on both Windows 7 and the versions that came after that. Now that we no longer have to support Windows 7, we have also dropped support for its touch behavior (that also involved mouse emulation) and have finally been able to address various issues with using touch.
As a result, non-standard uses of the touch infrastructure may show different behavior now, so you may need to have another look at your scripts. We would be interested to see them, though, and check whether they don’t expose faulty handling on our side after all.

1 Like

Hello @gert_leunen,
Thank you for the explanations, this makes sense now.

Here is the script I used during my tests : OnyxBetaTest.ahk (1.3 KB)

To use it :

  • Install AutoHotKey v1.1.30.03
  • Launch the script (double click it, it will appear in your tray)
  • Launch ONYX
  • Set 2 flash buttons in the Playback Buttons view
  • Hover the first flash button with your mouse
  • Press : “AltGr+a” (to learn the pos of the mouse for the “a” key)
  • Hover the second flash
  • Press : “AltGr+b” (to learn the pos of the mouse for the “b” key)
  • Then you can press “a” and “b” key to trigger the first or second flash button, and reproduce the steps I explain in my 1st post

Please let me know how your tests goes, I know I may have to redesign my script, but as you said, maybe it’s exposing faulty handling on your side so I’ll wait for you to tell me if you notice something!

Thanks in advance & let me know if I can help in any way!

FYI, we’ve been able to reproduce the problem and determine it was an issue introduced in our code. It will be fixed in the next build. Thanks for your cooperation!

1 Like