HELP! NX Touch Losing Functionality

I have an NX Touch which i have been using as part of my setup for 3-4 months now. It sits on my desk at home plugged into a computer which is plugged into a power conditioner.

I haven’t had any problems with it until today. Starting this morning when I woke up to start work, pressing Snap+Release on the console cuases all Playback buttons to stop functioning.

All buttons on the console will work as expected on any page indefinitely up until Snap+Release is pressed. All other buttons and encoders continue to function (Next, Last, Back, F- Keys)

Unplugging the wing and plugging it back in will regain functionality until Snap+Release is pressed again. Then all cuelists triggered by playback buttons get locked. (I cant even trighger them by selecting and using onscreen playback controls. No updates have been done. I am on the most recent firmware and still running 4.6. There is no damage to the wing itself and I have a gig tonight!

This becomes an issue especially because I’m unable to then activate Timecode cuelists for the next songs. Even clicking them in the cuelists directory doesn’t work. The cuelist im trying to activate will flash for a split second in the ACTIVE CUELISTS section but then disappear

Hey Dave,

Sorry to hear about the problems you are having. My only suggestion / question. Have you restarted the PC (Shutdown and wait a few minutes) recently. Definitely seems like a hardware issue, but just trying to help eliminate anything software or USB host related. I know you said you unplugged and re-plugged, but maybe there is still something cache. Sorry I can’t be more helpful.


Yes i have restarted the computer a handful of times. I updated to software and the problem remains.
I can use the Snap+any other button and it will work correctly, and i can also use Release+any button and it work correctly.

But once it hit Snap+Release for the first time i permanently loose the ability to fire any clue as if the relase button is being constantly held down. Even in the software i cannot trigger cues.

The console has not been damaged or been around any enviromental hazards.

You said you updated the software? So are you now running 4.8.1237? If so, there was a firmware update for the NX-Touch (it has more to do with the DMX Output) but it maybe worth trying to make sure. You could also try to launch the console tester and make sure the NX-Touch is responding correctly on the button presses. Basically to confirm if the button is “sticking”.

I updated the firmware as well the probelm remains. Also if i plug in my M-Play and press Snap+Relase on that it recreates the problem effectivly locking me out of the software

Pressing Snap+Rlease on either
wing will lock out the other/both wings and the software. This problem persists in older showfiles that are known to be working as well.

Does this happen on a new show file?

If you press Snap+Release on the virtual keypad of the software does it do the same thing?

i do not see Snap+Release as an option on the virtual keypad nor is it under the “Commnads/Playback Controls” that i can assign to my sidebar

i have also tried both wings in multible USB 3.0 spots and with different cables. and also through a USB-C port with USB hub and the same result

I tried to recreate the problem in a New Showfile and coudl not. All buttons and playbacks appear to function properly across all devices in a New Showfile.

Sorry…not the virtual keypad the virtual console view.

You may need to send a specific email to or call tech support if you have a gig tonight.

Sorry I can’t be of more help.

You may have a corrupt show file. You might try opening and then try saving it as a different file name. Also, if you have an older “backup” you could try loading that and see if it still happens.

is there a way to press both the Snap and Release buttons as the same time on the virtual Console? they are two separate buttons for me

I believe there are 2 methods…left Click and hold until it turns red or right click. Once red, I believe it acts like it is being held down.

i will call support. The problem remains even when i go back to showfiles before i even purchased the NX Touch. I have tried showfiles dating back over a year and tried loading from multiple sources. When i try to active a cue from any source now it changes the display from “-/X” (X being the number of cues in the list so sometimes its -/1 or sometimes its -/45) when trying to activate any cue now after pressing S+R it will change to display “-/-” DMX signal goes out and the lights are clearly attempting to run the cue but then releasing after a split second. I dont think i have it in me to start this showfile from scratch again there are dozens and dozens of timecoded songs and projects for multiple clients and venues.

also yes the problem happens even if i use the Snap+Release on the Virtual console and with no hardware plugged in. This now happens in all my showfiles. Im going to try a fresh install but if that dosent work im not sure what to do.

I would try a clean install and even make sure that the driver package is updated also. In programs / apps is where you’ll see it what driver package is installed. Also, I would see if the library is up to date and all fixtures have been exchanged. The fact that a new show file does not have the issue is interesting. Support may want to have a copy of the show file so they can reproduce and maybe even fix the file if possible.

Use the console tester in the diagnostic tools menu and see if a button gets stuck.
You could also have a power issue with your laptop where activating leds on the NX Touch or M-Play causes the voltage of your USB output to drop.
Try a powered USB hub.

It is not an issue with the hardware or my laptop as the problem persists even when no hardware is plugged in or if S+R is entered using the virtual console as Tim Suggested.

I was able to solve the problem by doing the following

It has something to do with MSC In although im not really sure how its causing the problem…If i go Menu/ IO Settings/ MIDI Show Control/ Disable i can prevent the problem from happening. Re-Enabeling MSC In causes the problem to resume. toggling this setting causes the problem every time even without loading the showfile and turning off MSC In restores functionality to all playbacks

This option appears to have been activated by default in a recent update and causes timecode functionality (really alot of basic functionality of the console and software) to stop working completely once S+R are pressed.

Is there a reason why pressing S+R with MSC activated causes this to happen? Is it not possible to receive midi time code and also MSC?