High CPU Load when movements/effects are running since V.1220


I just tested v1220 and 1221 Beta and saw that if a movement is running for some minutes the CPU goes crazy - like using 60-80%. If I stop the movement the CPU goes down again rapidly. I tried that on 2 different PCs now with the same result. So I guess thats def something wrongly implemented since Version 1220.

Tested the same ith 1219 the CPU stays at about 1-2% all the time. It might not be related to movements, but rather to the use of the effects engine.


Me again,

did some more testing and created a basic sine wave effect on a dimmer on a single device and this also leads to a CPU consumption of about 60%.


Could you share the showfile that is causing this ? Which CPU model?

DEH_2021-11-30_1242_Build_4_6_1220_0.OnyxShow (5.3 MB)

CPU Models were
AMD Ryzen 7 4700U with Radeon Graphics 2.00 GHz
Intel Core i5-4250U


We can’t reproduce those extreme CPU usages: what process is it (onyx.exe, dllhost.exe or one of the services)?
If it’s onyx.exe (the user interface), it could be due to improvements on the 2D plan which has become more responsive. If overall system load increases, though, the 2D plan will back off to not interfere with the output. You could also try turning off Intensity feedback in the fixture center: updating all fixture buttons also takes processing.


so it is the onyx.exe and it only happens if the devices are added in the 2d plan.


And without anything in the 2d view:


This was tested with the v 1220.

While doing the same with 1219 doesn show any increase or decrease of the CPU at all (with or without a filled 2d plan).

For that I took a new onyx file and simply added this 8 devices into the project.

I also tried some other fixture like the MAC 250. But the behaviour is the same.


1 Like

I’m curious of the computer specs., if it’s an older processor?

I think an AMD Ryzen 7 4700U (8CPUs) with 16GB of Memory is not that old ^^
I mean yes its a “mobile” processor, but still the change from 2% to about 50% only for virtualization seems a bit odd.

And as mentioned in the initial thread I also have exactly the same behaviour on an Intel I5. So its not related to the AMD CPU.