Install Error 27502. ANY SOLUTIONS?

Hi everybody, Thanks in advance for your help. I have been trying for days to reinstall Onyx on a windows 10 PC, but have run into this error repeatedly
I tried to re-install originally because my old version, (4.2.1045) was just sitting there spinning, and would not start any shows. Not sure but I believe it happened after the latest windows ten update on may 8. I’ve tried to google solutions but nothing has worked so far…also tried a restore of the PC to 5/7, but still get the same error
This is very frustrating. If the SQL server is broken, I don’t know how to fix that.
Same install works on othe pc that has the most recent windows update.
Any help would be appreciated…
obsidian install error|375x500

Could you run the AnyDesk utility and PM me your ID, so I could fix remotely?

Hi Gert, thanks for the reply …I sent the anydesk ID to your elation email address…let me know if you do not see it there

Just tried again…directly from gmail. Is there a different email I should try?

I get exactly the same issue and I had the 4.4.1192 version installed and tried to install the 4.2.1052 version and it just froze in the installation progress so I tried to install the 4.4.1192 version again and the error occured. I have tried to install the 4.4.1193 version since the and I got the same error every time.

Could you run the AnyDesk utility (from and PM me your ID?

Hi, I am running Windows 7 and have tried to install version 4.0.1010 and each time I try I get error 27502. Can someone help me?

So Onyx currently is not installed? In that case, run the following in a command prompt with administrative privileges and try again:

sqllocaldb unshare .\ObsidianOnyx


Do i run that command before trying to install or after? Also, what version of Onyx works with Windows 7?

I have the same problem, impossible to install and run correctly, impossible to uninstall.
I’d like to remove it completely because it reminds me my worst experiences of the “plug and play” era before I moved to mac…

If Onyx is currently installed, and you get the error when trying to uninstall, run the following on a command prompt with administrative priviliges:

sqllocaldb create ObdisianControl
sqllocaldb share ObsidianControl ObsidianOnyx

and try uninstalling again; if Onyx is not currently installed, and you get the error when trying to install, run the following on a command prompt with administrative privileges:

sqllocaldb unshare .\ObsidianOnyx

and try installing again


From the docs previously published, Looks like 4.2.105 was the last version that would run on Windows 7. Starting with the 4.4.xxxx A) requires Windows 10, and B) stopped working with generic (Entec designed) dongles (if you are using such a thing for the PC version).

The Versioning information is at this link: Obsidian Software Downloads/Notes Just scroll down to read all the updates (4.4.1186 was first version to implement the above changes).

I have same error problem 27502. what is the solution?
No way Uninstall
No way reinstall I try more versions 4.0.1010
4.4.1193. Doesn’t work…
I tried the Onyx Cleanup (April 08 2020) but, did not help…
Win10 64bit. The current version of 4.4.1193 crashed…



Did you happen to try the recommendations posted by @gert_leunen earlier in the thread? He is one of the developers and if those recommendations still don’t work, he’ll probably want to take a closer look with you.

Also, if you do get it fully uninstalled. Make sure all windows 10 updates are installed. Double check, yep the good old restart between. And then try the install (run as admin) again.

Hope this helps,


1 Like

Hi Watson

Thank you for your fast message.
Yes, I read all of the post in group. I read/look posted by gert_leunen before…
I was not able to achieve it what he wrote. I tried.

My idea, I Reinstall the Win10 again. But I am waiting yet. But if the mistake comes forward again?

Was beginning so when I Started the Onyx and a message window pop up Something /CriticalError/.
I wanted to delete it then.

Thx Gabor

Which error do you currently encounter? Any chance you could run AnyDesk utility and PM me your ID so I can have a look?

1 Like

having the same issue. Just on site with a clients computer. I have run all the windows updates and it wont let me install v4.4.1193 or 4.5

gert_leunen fixed it this problem on AnyDesk… : )

Windows updating I did it but did not help before…

Is there a how to fix it? I have tried all that i have found on this post. With the time zone differences i couldt stay with the clients computer. We are in lock down for another 5ish weeks. So I might be able to get the client to look at it. They were talking about just doing a clean install of windows 10. We were having issues removing or installing over 4.2. cheers mike.