Internal error opening Onyx

I’ve been using Onyx alongside capture lately on windows 10 and haven’t had any problems, but today when I tried to open it the program reported an error “Can’t initialize the LogDataChangedSynchronizer”.
I have reinstalled the program several times.
I have updated windows 10 to its latest version.
I have restarted windows 10.
Any help would be appreciated.


There could be 2 reasons for this:

  • registrations missing or inaccessible: could be due to new or updated AV, or a (registry) cleaner
  • Codemeter runtime is missing: you could download and install it yourself again, or remove the Obsidian Driver Package and launch the installer to trigger it to be installed again

I’m also running into this same issue, but reinstalling codemeter did not seem to work, and I’m not sure which registrations would be missing. Upon a full Onyx reinstall I get the following errors:

Unable to create a new show: you will need to create, load, or join one on first start. If that fails, Windows’ COM+ may be malfunctioning.

Exception when determining run edition:

If you’ve rerun the ONYX installer, Codemeter but also Visual C++ runtime should be installed:
are you running a registry cleanup tool? Looks like registrations are being wiped, could also be due to your AntiVirus: retry installing after disabling.
If that still doesn’t work, PM me your AnyDesk id, so I can have a look into your system