M1 External Monitor Problem

Hello All,

I recently tried to use an external monitor on an M1 running 4.0.1010. The monitor connected properly & I could move the curser from the internal display to the external monitor without any issues. However, I couldn’t for the life of me figure out how to configure a window layout on the external monitor. In the workspace & display settings menus, it was as if ONYX was not recognizing that there was an external monitor attached. I tried rebooting the console & even reinstalling the OS. No change. Is there something I’m missing? Or is external monitor support still broken?

Thanks in advance,


Hey Rob,

Did you make sure to enable the second screen in the ONYX display settings? Sorry I can’t provide a screen shot at this time. I believe it is menu/system/display. Or something like that.

Hope this helps,


There are issues using DVI for the external monitor that we can not correct as the driver for the Intel chipset isnt developed any more.
Use VGA and make sure to toggle it in the displays menu.

I was using the VGA connection - sorry, I should have specified that.

I toggled VGA in the menu, but it didn’t seem to make a difference. I could see the cursor on the external screen, but couldn’t create a workspace on it. I’ll try exploring further the next time I’m working with this setup.

Hi guys - this has now become time sensitive. I’m on a setup now, and am having the same issue. Different M1, also running 1010. The board is sending a VGA signal to the external monitor and I can move the cursor over to this monitor, but there is no way to configure it or add a window to it.

Help, please!

Hey Rob,

Sorry to hear you are still having issues with this. I’ve only used a second physical display on a Compact and M2Go. Is it possible that the workspace “view” is “under / behind” the one on the built in screen? I know on my PC, I sometimes have to move it out from under the start-up splash. That’s the only thing I can think of. Odd, that you have mouse control…so at least the OS is seeing the connected display. Is it possible to try 4.2.1045? Or maybe some screen shots of what you are seeing and the display settings? Wish I could be of more help, but you might need to work with ONYX support directly.


If the screen does not have the sidebar there is unfortunately issues between the driver and windows not telling ONYX the right info.
Maybe try a different screen model.
There is no setting you can do to fix it either, it has frustrated our team a lot too as the driver is not communicating properly.