NETRON CLU 1.007 / Beta Firmware 2.93

An improved version of CLU and matching NETRON Beta 2.93 are avaiable for testing.
This includes support for RDM capture on DMX Input ports, for example to transfer RDM for Robe Follow Spot Systems.
Many improvements were done to the processing speed of all NETRON nodes, especially when capturing DMX data.

The CLU tool now manages all settings natively in the application window.

NETRON firmware can be updated to the nodes simply with the arrow in the CLU application. Version 2.92 is also included, the “RECOVERY” button allows to browse the firmware file to roll back if desired.

Please report back any concerns or positive feedback. We are looking for many testers for the Robe FollowSpot bridge.

NETRON CLU + Firmware 2.9.3

NETRON Firmware Beta 2.9.3

	Release Notes for NETRON Central Utility
		(C) 2023 - Obsidian Control Systems

V1.007 (09/21/2023)

Includes Beta Firwmare 2.9.3

New features

All device settings are moved into CLU application
RDM support on DMX Inputs, for example for Robe Followspot Systems.
Create dedicated Art-Net network between two devices and assign the same Universe numbers on both sides.
Different NETRON devices can be used on In and Output. All devices must use this firmware version
Universe Browser Home Screen, allows for instant assignments of Port Universe numbers without navigating the menu structure


Revised RDM communication to always send complete DMX frames. This increases compatibility with some manufacturers fixtures (e.g. ETC)
Improved Merge Performance on RDM10. Set Input Refresh Rate to 40Hz to activate the high speed merge algorithm
Added red blinking LED feedback to DMX ports to indicate lost Ethernet traffic
RDM package structure
Home screen always shows IP address on the bottom

Bug Fixes

Resolved Cue Playback sometimes not triggering or sending only partial cues
Resovled Cue Playback on DMX Loss settings
sACN Multi-Cast subscription was timing out on EN4
Sometimes the nodes subcribed to unnecessary sACN Universes 1 and 4 through 11
Resolved sACN priority handling with Zactrack Tracking Systems

Known Issues

Resend Ethernet on Cue playback sometimes inconsistent
Remote Input not implemented in CLU application. Use device web interface
Load / Save Settings not implemented in CLU application. Use device web interface

V1.006 (11/10/2022)

Includes Firmware
EN12 V2.9.2
EN4 V2.9.2
EP4 V2.9.2
EP2 V2.9.2
RDM10 V2.9.2


Identify uses LED and Display level @ 100%
Node Web UI refinements (colors/text sizes)

Bug Fixes

Corrects sACN and Art-Net sometimes missing frames on 0s changes
Fixed Backup Export / Import for EN12
Improved sACN priority handling
Fixed node discovery with 169.254.x.x addresses (e.g. no DHCP Server)
Improved RDM compliance
Corrects RDM10 performance hiccups

V0.1.004 (08/13/2022)

Improved device table layout
Improved device discovery speed and UI feedback
Increased speed of device online/offline monitoring
Improved reliability and speed of firmware updates
Added “About” screen with Version Number, Release Notes, Help File

V0.1.1001 (08/01/2022)

Added status feedback LED to show nodes online/offline
Improved discovery speed
UI recalls position and size

V (06/23/2022)

First public beta version
Supports discovery on all network ports over LLRP
Allows IP configuration, Identify
Firmware updates for one or multiple devices
Direct access to all device web pages

Hi Matthias,

I’ve just installed the new CLU and the last firmware on our EN12.

However I don’t see the new menu “DMX Input” on the CLU. Is there something special to do ? I tried to put one dmx port in Input mode but it still disable the RDM.

We would like to test the RDM In with Robospots.


No new menu was needed.
Simply set a DMX port to Input with a Universe number and the Art-Net protocol.

Well, by setting a DMX port in “Input”, we still can’t get our robospots to work.

The Robospot station cannot detect the Robe BMFL. Whereas by doing the same thing on a Luminex node, it detects it almost instantly.

When I put the port in “Input” the RDM always remains disabled (see photo). It must be activated to detect fixtures

RDM Processing is activated on the node.

Both sending and receiving EN12 need the new firmware.
The CLU and web ui are incorrect, ignore the RDM disable text.

Set port 2 on that node not to the same universe, possibly this confused the node to try to receive dmx with rdm and send it out on the same node. This may need some optimizations still.

I have personally set up several systems with EN12 bridges and I know it works between two EN12s running 2.93

Ok I’ll try that and let you know if it works.

Thank you !

Hi team,

I am always having issues with any of the devices not being seen by the CLU. I have included a screen shot of ONYX and the CLU on the same computer no firewall and ONYX see’s all devices yet CLU only see’s two,

I have updated all the firmware to the latest beta version as a test. I noticed the RDM 10 units are currently running 2.9.4 and the other EN4 nodes are only 2.9.3. Is this correct?

Keep up the great work but still waiting on the official release of the network switches. Been holding off for nearly two years now. They have been on the website for quite sometime now.

Is there going to be a full size switch Fibre inputs?

Can you do VLa’n’s with the NS8’s?

Keep up the good work.



Have you tried a different PC?

I’ve downloaded the CLU a while back to look at it, but never used really used the CLU before. I’ve been testing out the new CLU and beta firmware to update my EN4’s. So is this supposed to happen?

I search for the devices on thr CLU and they show up with green dots. I see a red world and notice there are sharing IP addresses. I change an address and then all the green dots turn read slowly and never turn green again.

I wait minutes and research for the nodes and nothing is found. Then I wait longer and sometimes it finds some nodes and sometimes it doesn’t. I restarted the computer a few times when it doesnt find any nodes, and sometimes it works and sometimes it doesn’t.

Do i have to wait a certain length of time after I change an IP address for the system to refind all the nodes?

Also how many nodes can i update at a time? I tried updating two and a time it seemed to work but the screen CLU didnt update that the node was updated.

When i do four or five then it only seems to update about three of them and I had the nodes and CLU lock up during updating and never seem to find them again. I had to uninstall 1.007 and went to 1.006 to see if it would work and it did. Now im back on 1.007 and it seems to be working like described above.

This is a little frustrating right now as im getting things ready fornthis install. Any info here @Matthias or @mgerardi could help me out.

Thank you

Also i just tried updated multiple nodes and after i closed the program because it was not finding them again i reopened thr CLU then i see web and firmware are diff on those two units.

Also after updating firmware on a unit it reverted back to the old IP from the factory and then I was having problems with the clu funding two units. Do you have to manually go in and change the IP address every single time two units have the same IP address?

Also after updating all these units it’s erasing all my settings in them. That’s not going to work too well if they’re on trusses up in the air and I can’t get to them and change their settings. Anytime I would have to lower a truss in this building, it’s a union call.

Hi Matthias,

Hope this find you well.

I retested the network a couple of days ago.

I had some very strange results again. Sometimes both computers on the same network see all, then I would refresh and one would see a couple and the other none. Then another refresh they would swap and one would see 3 and the other all etc.

Both computers would see all nodes in Onyx the whole time.

Both computers are on Windows 10 Pro.
No firewall.
Simple non managed 1Gbit switch.
I had them joined in XNet and then also in stand alone.

Have taken another picture of the strange results.

I’ll give it another crack over the long holiday weekend here.

I also have 9 EN12’s yet to do. However that is in the concert racks and I don’t want to test a beta firmware till its a release.

One other thing I have found if I try to change the Universe number in Onyx the node doesn’t accept it but says its changed in Onyx but not in the node. If I change it via the CLU or on the actual node it updates in Onyx straight away. Has anyone else found this?

Kind regards


There is something wrong with the 2.92 for the nodes. I upgraded 10 of my EN4’s and the DMX-IN is not working well at all. It seems like it’s a corrupted data because not a lot works like it’s supposed to. As soon as I down graded the nodes to 2.8 everything is working fine again. This small issue has caused me to have a couple weeks of pain in the butt trouble shooting on a couple NBA games that’s people were not happy about. I’m not trying to make this a complaining site but I need to let you know how serious this problem is as I didn’t read anything on the forum with this problem before upgrading.