Netron EN12 Showing Web Firmware 0.0

I have an Netron EN12 which I was attempting to update the firmware of. For some reason it errored during the update process. It will still output DMX and function in that way. But, I can no longer access it via it’s IP nor can I ping it on our network.

When I use the menu to see info it displays a firmware version of v2.9.2 but a web version of v0.0.0. A factory reset changes nothing and I cannot get it to come up when trying to update it again via IP/update.html

Not sure what else to try at this point. Luckily its functional so I am also not super concerened. Mainly I want the web connection to fire cues via Companion.

Have you tried using the NETRON CLU? If not, I’d start by trying this. It will hopefully see the device and allow you to access it. There is also an option to update both the firmware and the Web UI. Which if you do that manually, you have to do each file seperately and in a specific order. Which maybe why you aren’t seeing it properly. If that doesn’t resolve your issue, you may want to reach out to support as they may want to ask some follow up question and try some things, to better improve the product line and the utility.

Hope this helps,


I have not as I am using a Mac and lack a Windows computer to use it with.

When you downloaded the firmware .zip, there should have been a 4in1_Web_V2.9.2.nfw to install separately. Did that get installed. Also, double check your IP and your subnet. I’ve experienced that after an update, the unit reset it IP settings.

A recovery process is explained in the user guide on page 40. Reupload the 4in1 img file to recover the web page.

If the system menu is corrupt and or cannot be opened, then the Netron device can be updated from an IP
address e.g. EN4 EP4 EN12 EN12-45 - USER GUIDE 2022-05-25.pdf

When I try this it does try and update the firmware. But, after a moment it will indicate “Update failure”.

use a different browser, and possibly disable your antivirus. Some like AVAST block the data transfer.

Disabled Antivirus and tried a different browser with no success.