No response from fixtures

This is my first attempt at using Onyx and the NX DMX.

Running on Windows 10 Pro, touch sensitive monitor ONYX ver
I think I correctly have set up all the patches, Groups, a few test presets (Red, blue, green) washes for the PAR LED lights. I have set a souple of simple Cue items.

I’ve been using “Learn Stage Lighting” for my tutorial

What am I missing?

I’ve watched several of the videos and they all use the Capture window as proof of concept, which I have been unable to install, but none show actual lights turning on and changing color.

I created a new project… Added Generic (5) RGBI PAR LED instruments with their DMX codes (210-214), Group(1), 2D, Preset (intensity at 100%), and a Que with a red preset added.
When I run the Que I see the bar go across the screen BUT NO Lights come one.
I am getting desperate to get this working to create a full set of queues for my facility.
Almost ready to pay for help… Very Frustrated…

what Onyx version?

In addition to What ONYX version, what DMX Port did you plug into on the NX-DMX. I’m guessing you are only using 1 universe of output.

I think it’a problem with the interface. Do you habe a DMX-Tester ? Is the NX o. k . and correctly installed ?

I do not have a DMX tester. The system was up and running prior to this upgrade of the console from a ShowDesigner 1 to the ONYX software.

Is the NX DMX installed properly? I do not know! I took it out of the box sat it on top of the computer plugged the USB cable into the computer and NX DMX box. The lights came on so I unplugged the DMX cable from the ShowDesigner1 and into the left port on the NX DMX with a 5 to 3 adaptor.

Have I missed a step or installation peace?


When you plugged in the 5-3 adapter into the left port of the NX-DMX, what was the port letter? Did you try the right port? There is an internal routing for the DMX ports. At one point, I believe some devices showed backwards. In short, try the other port and see if you get control. Otherwise some screen shots of the patch / and routing page of the NX-DMX maybe needed. I also think you posted about “erratic” light behavior and it was mentioned to make sure that both the patch and the physical light were in the same fixture mode.

Hope this helps,


Left port of the NX DMX is marked “A” - I tried the right “B” port - Nothing!

Sorry missed this screen shot…

NX DMX is not for sACN. You need to go to the DMX Settings further down on the left side.


In the screen shots you provided a couple things.

  1. The cuelist indicates that the fader is at 48%, but the cuelist is not active (-/1). There is only 1 cue in the cuelist. What happens when you press the Go button for that cuelist?

  2. That is a screen shot of the EtherDMX page. I was referring to the DMX Settings with the Local DMX information. What colors are your DMX ports? Can you confirm they are both set to output and at least one of them is for Universe 1.

Sorry about the wrong page… here is the one I believe you asked for…

Here is my Que List page…


Okay NX-DMX outputs look correct. I would be curious to know what the DMX port lights colors are.

But the bigger issue might on be your cuelist, you have only set your colors (RGB), but you have no intensity (Ch) assigned to it. You need to add the intensity channel to a value for the light to be on.

In the image below I’ve quickly mocked up your cuelist and have added a second cue to turn the lights output on. I’ve also added a “programmer” window to show what your original cue looked like, before adding the Intensity. Try clicking the Intensity tab and then increasing the value.

Hope this helps,


Universe 1 & 2

Try this. A simple three cuelist showfile patched and addressed based off your pictures.
Cuelist 1 - Intensity at Full + Color Combinations
Cuelist 2 - Intensity Only (works with Color Only)
Cuelist 3 - Color Only (works with Intensity Only)

Generic RGBCh Profile Test_2023-09-13_1623_Build_4_8_1244_0.OnyxShow (1.6 MB)
Hope this helps,


Okay Watson
I imported your show file and ran the Queues - nothing
I noticed on the patch page that the Generic RGBch has no settings.
I am still not getting any response from the fixtures using your Ques
I have 2 green lights on the NX DMX box.

I’m getting very frustrated and nervous that I will not have anything working our first show comes around next month.

Are you available for a consult and possible connect to my system to see first hand what I am screwing up?

Thanks for all you help.

What do you mean on the patch page there is no settings? Screen shots?

Also I believe the green leds indicate dmx in and not out. But the screen shot you provided indicated the setting was set for out and on the current firmware of 4.11. I’ll need to test / verify the led status. I’m beginning to wonder if we need to use the console tester to verify that the the NX DMX is responding properly.

I sent you a message directly about additional support.

Phill Seaman