nx2 problem

Hello, I have a problem with the nx2 console, the xlr ports 3 and 4 have stopped working (I don’t know since when). The first step I have taken was to reinstall with the software version “ONYX OS 4.8.1239 (14. November 2022)” but I still have the same problem. The port leds work with the corresponding color and, if I configure these ports as dmx in, the leds also light up green but the 2 ports do not give a DMX signal.
I hope you can help me, I don’t know if the problem is something with the firmware or directly the PCB has been damaged. Thank you very much for your help.

Please fill in a support request.

Support Request (obsidiancontrol.com)

THANK u so much Matthias

Hi every body, last days i wrote to suport request abou my nx2 problem, they tell me i have to update firmware in dmx cards. I m waiting for any update firmware but any answer since two days. i was looking here in forum and download website but don t find nothing about it. My question is ¿where i can get the update firmware of dmx cards for NX2 console? and if its possible any pdf explaining the process. thanks in advance

NX2 firmware is included with the software. Check under tools in the menu. There should be a firmware update utility.

Link to Release Notes explaining units needing firmware update. Download Old2

I’m trying to find the specific documentation for updating it, but quick overview. Select the module. It should tell the current version when you check for a newer version it will be in a folder under NX2 (or at least that was how the older consoles worked). Look for same module and check version number. If newer select to install.
Maybe try searching the forum for firmware update or the manual.

Hope this helps,


@Watson thank so much, i will instal SO 4.8.1237 and follow the release instructions to try solve it.

Finally after update dmx cards have the same problem, last option check the dmx cards exchange harness cable between both cards and have the problem in the same board. think is necesary change the dmx card. i was looking in elation parts but the only send in EEUU, how can i buy in Europe? thanks

I’m sorry you are still having an issue. I just realized that they now have version 4.8.1240 online. You might give that a try.


If you still have an issue. I’d contact support via email. They would be able to help you better.

Hope this helps,


thanks @Watson, i did it. finally is one of dmx card


Also, I remember some post about dmx cards maybe loosing the configuration and needing re-assigned. I thought the firmware was suppose to fix that. That said, have you tried (after the updates) opening the console tester and confirming which univ is assigned to which port? You might even try changing and saving and then changing back. Do some searching for DMX assignment or some like that. Maybe a quick re-assignment will solve your problem.

hi @Watson yes the re assigned configuration on dmx cards was the first check that obsidian support ask me but my set up is correct. thanks for your tips watson i ll continue looking for the problem