Obsidian Beta 4.1.1034

This beta is designed to eliminate COM+ installation issues and fixes a few bugs reported.
It adds support for NX console hardware.


This version is designed for all existing consoles and PC systems.
Install PreReq file first, then the version itself.

Please provide feedback especially on PC systems that failed to install.

4.1.1034 (08/01/2019)

Added software support and firmware for NX2 / NX Wing / NX DMX

Fixes and Improvements

PC Installer: Eliminated dependency on Windows COM+, avoiding most of installation and runtime errors on PCs with damaged COM+ (after driver updates etc.)
Fixed saving custom fixture type when using color or gobo wheels
Fixed 2D plan showing negative intensity values for virtual dimmers
Fixed gobo pictures not showing when moving show files to different hardware
Fixed UNPATCH option not working properly when patching fixtures to DMX addresses already in use
Fixed RDM PortId issue
Fixed timecode initialization error on GUI
Fixed intensity values not updated in title controls
Fixed Onyx installing to more recent SQL Server localdb versions: such show files cannot be loaded on consoles
Fixed CITP thumbnails not showing on consoles
Fixed library update to search and accept both SetupFixtureLibrary and OnyxLibrary extensions
Fixed “Maxxyz” name still showing in Preset/Cuelist reports


Works perfectly on windows 10 thank you.

So the AB X-Fader problem not fixed…

Just tried updating from 4.0.1010 to 4.1.1034, getting the following though:

Error 1722. There is a problem with this Windows Installer package. A program run as part of the setup did not finish as expeted. Contact your support personnel or package vendor. Action LOCALDB_Start_Install, location: …MSI87F0.tmp, c…

Prereqs were installed first!

Just installed this preview onto my home computer, Win 10 without all the latest updates, and it installed first go. Back story. I have NEVER been able to install MPC, or Oynx onto this computer before in the three years I have been using the program. It always came up with a 1720 error, unable to process database script.
I’m happy!!

1 Like

Thanks for sharing!

I tried to update ONYX (Last stable version) to this beta on my PC, but installation stops with this message.
After I installed OnyxPreInstall drivers, nothing changed and update fails. Help me!

You need to install the new preinstall package, not the one shown in the popup (that is for the release)

try this https://obsidiancontrol.box.com/s/3mdh322cag2non97li0l7kl12f8gb15a


It helped! Thank you!