ONYX / DYLOS Beta 4.3.1177

We invite users to install and test this new ONYX beta software that includes a first version of the DYLOS pixel engine.
Please read these general notes:

DyLOS pixel engine activated (currently limited to 5 zones per show, 1 layer per zone, all content scaled to 256x256 pixels internally)


  • ONXY PC for Windows10 64bit
  • NX2, NX4
  • M2GO HD, M1 HD
  • ONYX and M-Series USB devices
  • ONYX Key
  • Martin One-Key (with LJ or ONYX License)

This software will not install on older Windows and unsupported consoles.

Changes to ONYX licensing

  • Support for ENTTEC USB DMX devices is removed.
  • Support for Martin Ether2DMX8 as license key is removed. The device will remain working as an Artnet node but not unlock 128 Universes of ONYX.
  • OSC support restrictions added to FREE version. OSC Playback faders and buttons are delayed in execution. Full OSC support remains available for licensed systems (USB Keys or with ONYX control surface) and all consoles.
    For more explanations please read the blog post:

4.3.1177 (08/11/2019)

Fixes and (performance) improvements:

  • Provide load/default shortcuts on parameter group popup
  • Show generators in library breakout view
  • Fixed artifact in Line effect shader on DyLOS
  • Fixed renumbering multiple ID numbers of DyLOS zones skipping 4 ID’s every following zone
  • Improve media saving speed
  • Fixed Programmer and Cuelist Values not handle zone deletion correctly
  • Fixed DyLOS engine crashing on fixture(-part)s that don’t have any channels viable for pixel mapping (being mapped in a zone)

4.3.1176 (01/11/2019)

Fixes and (performance) improvements:

  • Media resynch button now supports different scopes
  • Creating new show now shows an option to resynch media (map) on the system into the new show (default OFF)
  • EDIT can be used as well to rename library folders/slots
  • Zone page selection not correctly updated when resetting to recorded settings
  • Multiparts placed in visualization mode on the 2D stage do not show pixel information
  • Newly added fixtures would not be pixel-mapped to until restart
  • 2D Plan (Onyx) crashes when enabling/disabling zone preview
  • Async import of media files (improves responsiveness)
  • Some DyLOS shaders don’t work in Release build (like Line Effects)
  • Fixed Pan/Tilt invert/swap
  • Delay OSC playback control if no license has been found
  • Show descriptive labels for some DyLOS parameters
  • Gobo images with - in filename are saved incorrect (library editor)

4.3.1175 (21/10/2019)

Added DyLOS support for multi-part fixtures
Fixes and (performance) improvements

4.3.1171 (4/10/2019)

Added DyLOS pixel engine (currently limited to 5 zones per show, 1 layer per zone, all content scaled to 256x256 pixels internally)
Improved user interface focus and navigation (arrow keys activated) management
Moved to 64 bit

Third Party Licenses
This software uses code of FFmpeg licensed under the LGPLv2.1 and its source can be downloaded here


Is Dylos going to be available for the M6?

Yes but it will require a mandatory hardware upgrade. It is not available yet.

1 Like

Hi Gert,

Great to see feedback is reviewed and new features are implemented.

Please find my video below clarifing the DyLOS zone renumbering bug.
(sorry for my macbook to take off at the end ;))

(Updated link)


Hello Stephan, I don’t seem to have access?

I’ve updated the link!

Sorry, for some reason I thought you were referring to the zone composer. We’ll have a look.

Getting familiar with Dylos, the platform is excellent. Looking forward to more effects, particularly a text generator.

Two issues so far:
Martin license key is not unlocking LIVE output even after “refresh”

Some confusion with deleting zones. Do you do it through the patch? Or in the 2d plan? Both?

Thanks team, fantastic work, keep it up!


Deleting a zone from the 2D layout only unregisters the pixel mapping, the zone itself will still exist and can be placed elsewhere in the 2D layout later. For actually deleting the zone (freeing up things), do that from the patch (pixel mapping will be dropped from 2D layout automatically, in that case).

Could you send a screenshot or something of your OneKey contents (for example, after pressing Manage button in the About menu).

Hi All,

Install worked fine on two machines. Nice to finally see pixel mapping.

I have found that of the 3 USB keys I have my 2 original M-PC keys work fine for unlocking but the LJ-2 key doesn’t unlock the software.

I tried the same key on a V4.2.1047 and the key unlocks the software to 128 Universes. In the note about licenses it says it should unlock.

@Art_Aleksashenko is your USB key a LJ-2 type?



Was keen to get to play with Dylos and installed it on a laptop which already had Onyx on it. After installing the new Beta, when running I repeatably get 2 rror messages as below at Staring Live output. Clicking OK on them makes Onyx continue to load but after selecting of creating a show, it hamgs on optimising show. I tried uninstalling and re-installing, but no improvement. Is there an installation cleaner for this release to try next?

1 Like


also getting these errors.
just got them again after tracking down and uninstalling or deleting or transferring to removable disk anything and everything to do with Obsidian Control Systems/Onyx or Mazzyx.
Currently stuck on infinite optimisation, will repeat the complete delete/uninstall and try installing the latest Onyx before installing the Beta…
Any other suggestions @admin/@mods?

Unfortunately, I just noticed the Martin LJ license dropped off the license search list. That was by mistake and will be fixed in the next beta build

I identified a previous 3.71.* M-PC install may cause leftovers that prohibit the latest beta from working. Here’s an adjusted procedure for trying to make it work:

Thank you!
Fantastic support

With my M play and m touch plugged in it’s still showing only as the free version is this a bug

No bug. M-Play on its own never unlocked the system, only a dedicated key or NX Wing will do that.

congratulations to the entire DYLOS team
Something that worries me is with the parts of the devices when cloning, the information from one wing to another is very wrong.
and when performing a swap it doesn’t

I am grateful that this works for the future since in times it would be the most effective

Still can’t get past the SharedMEM errors I posted. I’ve tried uninstalling 4.3, reisntalling 4.2.1057, then uninstalling it and reinstalling 4.3, rebooting in between each step. Tried uninstalling 4.3 then running the 4.2 clean tool, then reinstalling 4.3. Unfortunately same result every time on this partictuale machine.