Onyx Install Failed - MPC doesn't want to be uninstall - Error 27502

In the end I reset my windows and did a fresh install.

Try this updated tool


install error as well. I used the new cleanup tool. still no joy. The same uninstall issue.

redownload it, should be Aug 17. I added some additional checks.

I’ll try it once back in the office

After running the cleaning tool (17th August)
Then reboot
Then try to install Onyx 4.0 (freshly re-download), I have another error message:


@Matthias and @Sylvain_Guiblain,

I have the exact same error falling the exact same procedure. Ran M-Series + Onyx Clean up (Aug 17th) as Admin. Restarted. Checked for Windows Updates again (just to be sure nothing new overnight). Restarted. Re-downloaded Onyx 4.0 Installer Package and started to install.

I saw a Facebook post about some log files. I’m going to try to locate those now to see if that helps you narrow the problem.


Hi Guys,

Just tried to do a install on my Surface Pro and got a fail. SP4 - 8gigs - Win 10 Pro V1803.

Any assistance would be handy.

Also has anyone managed to install on a Windows 7 Pro 64bit machine yet?



Try this, then reboot, reinstall


Hi Matthias,

That fixed my install problem thanks.

I would also like to add the new cleaner worked with Windows 7 64bit and so does the new Onyx V4 from what I have tested so far.



FYI, Successfuly installed on Windows 10, 64.

Windows 8.1 installed fine too but kept spinning on first launch. Upon restart of the computer it launched without further delay.

Hi Guys.
I’m trying to create a bootable USB Stick. and that’s
the message i got…
(Image path in NULL. Please report this error to the author of this application.)


Hi Steve,

Were you able to get this working? I have been pulling my hair out trying to get it to work and to no avail!
I tried the cleanup and reboot then install and get the same error you get. On W10 Pro 1803 version.


Hi Manu,

Yes I did end up managing to get it to work. I used the clean up tool that Matthias provided in the following post on Aug 18th.

I tend to run the cleaner, restart like they suggest and then run CCleaner and registry cleaner from glarysoft to clean any other junk and registry keys left behind. I then restart and do the whole thing again in case. Just to be sure.

Then I try again with the latest version. 1010. and then restart,

This time and the last M-PC beta have been the only 2 times I have ever had a problem with installing the software.

Hope you manage to get it work.

Keep us in the loop.



Hi All ,

I have the same 27502 SQL error above , I have deleted the original software installer package , ran the Onyx Cleanup V1 , restarted , ran the CCleaner , restarted and ran the Registry cleaner and restarted . I then downloaded the installer package again , ran it , got up to the modify/repair/remove screen and then hit the SQL error .

Any suggestions on what else I can do to get Onyx back up and working ?


I have same problem!
Os Win 10 Pro. Firewall is turn off.
Cant start Onyx. Uninstall or reinstall same not working.
Please help!

Hello everybody!

This post might just help you all out…

Good luck!
//Martin Hedstrom

tried this w/ no luck. any updates? I am running on amd machine w/ hardware management of a SSD. windows 10. really not looking forward to resetting windows, but this is getting real old trying to fix.

ive tried all these work arounds and nothing is correcting the issue. I do not have the option of backdating windows, anyone know an alternative for getting onyx installed…

I found this on the forum and it workt out great for me.
I hope it will work for the rest of you as well.