ONYX/MPC not sending output to Enttec DMX USB Pro MK 2

Hey guys, new here so am unsure if I have posted to the correct place or with the correct info. Apologies for any obvious mistakes.

So I recently bought a Enttec DMX USB Pro MK 2 and used it with a generic light for testing purposes. In order to test the light and controller, I tested using the DMX Pro Manager interface(One that takes you to http://localhost:55555/) and the lights seem to work fine when tested with the test patterns and slider faders. I used another software(I think it was called lightworks) too in order to test the light and got the light to do something, but cant get my head around that software.

I have used Martin MPC/ONYX in the past and so would prefer to use this software but the software seems to be unable to send output to my controller. When I go into “Menu>DMX Settings>USB2DMX” and on that screen, I can find my device, with the following settings:
Device type:NA
Firmware version: NA
RDM Capeable: No
Direction: Out
Universe: 1

I am certain that I have plugged the light into Universe 1 of my controller. Another thing to note is that the controller is blinking white only but when I had gotten it to work with the DMX Pro Manager software, it was blinking White, Green and Yellow.

I have read through a lot of forums but am unable to find any solutions. Please suggest solution as I really like the ONYX interface but it not working may mean that I may have to find other alternatives.

Raj Jayswal


The Enttec DMX USB PRO Mk2 does work with ONYX. It sounds like you have a driver issue. A few questions…is the DMX PRO Manager on the same machine as ONYX? Do you know what firmware version is on the Enttec? I’m running firmware 4.14.

I use the DMX Pro Manager on the same machine to install the necessary driver that is needed. Once installed and the firmware is the most recent, I close the DMX Pro Manager and forget I have it. Launch ONYX and it sees it. Make sure to install the FTDI driver also. Once connected it should show up in ONYX with a serial number and Firmware version. Also, it will flash between white (which is actually blue) and green. Blue for standalone / on and green for universe one.

Hope this helps,


Hi Watson

Thanks for the quick reply. The firmware on the Enttec is 4.14 being the latest. I installed the drivers again but still no progress. The DMX pro manager and ONYX are on the same machine and I have tried to use them while both running together as well as having them run individually. I made sure to install FTDI drivers while installing DMX Pro Manager.

Unfortunately still no progress. Would you have any other suggestions?


Hmmm. After installing the drivers, did you restart the machine? When you go to devices, do you see the same info as in my picture?


Just as an FYI, I have emailed ENTTEC and Have also spoken to them on the phone, I am hoping that they can direct me in the correct direction. Untill I hear back from them, Please see attached screenshots and inform me if I am doing anything incorrect.

Just curious, under the advanced menu of the device properties, is the Load VCP checked?

Load VCP is ticked. I think it may be something in MPC but not expert enough to understand what the problem is. Let me know if you feel it may be something else. I am still unsure how to tackle this issue. I have already uninstalled and reinstalled all the drivers and softwares. redownloaded ONYX as well but still no luck.

Sorry. Past this, I’m not much help either. I’m looking for a document that was out a long time ago on first using the Enttec with ONYX (MPC) but haven’t found it yet. I thought it described making sure to check the Load VCP. On my fresh install, I installed ONYX, then DMX Pro Manger to get the driver. Restarted. Launched ONYX and it worked. So past this, I also can’t be of much help. There was a post that someone had a bad Enttec once, but yours was working with other software. However, ONYX is seeing it as an “Open DMX” and not a “DMX USB PRO MK2”. Are you able to try on a different machine?


1 Like


Did you look here?



1 Like

Thanks for the link Watson. I have just spoken to someone from ONYX as well and he as you had suggested, has suggested installing the softwares on a different computer. I have just tried that. and we have success. So this just leaves me to wonder what the problem might have been on the first laptop. At least we have a confirmation that there are no issues with the hardware now. I am creating a fresh user on the laptop that the software didnt work on and will try again.

Thanks a lot for the help.

Glad to hear you got it working. Good luck finding the source. If you do find it, maybe post the solution for others in the future.


Thanks Watson. Will be posting the details about the problem and a quick guide on how to solve it too once I find out what the problem was. I still havent found the problem. I am trying to compare the settings in Martin and in windows on both the devices.


Hi Watson,

I have the same problem that Raj had.
I’m using a MK2 from Enttec, and it works properly with the software from Enttec and with Qlight.

I see the interface in the DMX setting menu but only under opendmx not with pro selection.

I try the installation on a different computer, no luck same issue

I have the last driver for the mk2 and the last firmware version
The onyx version is the version available today
I’m surprised because I was using it with MPC and it was working since I update to Onyx, no more DMX output.

Do you have a cue for me (and all the other one)

Thank you

Hi Stephane

What computer/Laptop are you trying to send output from.

I was running the device on a surface book. On a surface book the keyboard and screen can be separated. The keyboard is what has all the USB ports. When I connected the controller onto the Laptop, I remember I once separated the screen and the keyboard components while running ONYX. I think this might have messed with the ports or something along those lines.

I contacted Enttec and they blamed it on ONYX. I would suggest trying it with another computer and if you are in Perth, I am happy to meet you and assist you if that is needed. But First of all I would recommend you to format a computer and try it on a fresh system(NOTE THAT THIS WILL REMOVE ALL DATA ON COMPUTER SO MAKE SURE YOU HAVE A BACKUP).

Let me know how it goes and if not then we can continue troubleshooting.

But as mentioned, feel free to give me a call on +61 469 792 995.

Hi Raj

I used un Dell Laptop Inspiron 7520 under win 7 (i7 with 16 gig of memory).
I already try on under a different Laptop with the same result, no output but the software seeing the interface.

Thank you for the offer of helping me but I’m in Canada.

I will try to throw the evolution of this situation on the forum and keep everybody updated.