Onyx not working with Enttec interface

Hi guys,
There is something wrong with my device and Enttec interfaces:

  • Windows 8.1 pro in english 32 bits updated
  • Processor i3 64 bits
  • Interface DMX USB PRO MK2 firmware 4.1
  • Onyx 4.0.1010


  • Fresh windows install
  • Interface works with Enttec pro manager 2.43 (it let me know cabling, usb, lights and interface are working)
  • Onyx software detects intarface and interface stars blinking in green when software detects it
  • Not errors on instalation
  • Not errors on event viewer
  • I already deactivated firewall and antivirus during installation and operation
  • It seems software/computer detects the interface but somehow it doesn`t pass de info.

Any thoughts?

Couple questions…

Have you used this enttec before on ONYX?
Just verifying that all you fixture(s) are patched to Univ 1.
What does your DMX output window show?

Also, the firmware you listed is 4.1. Current firmware is 4.15. When you run pro manager does it prompt you to update firmware? If not you might download the updated firmware file and update to 4.15.

Other than that everything looks good. Get back with these answers and I’ll see what else I can assist with.

Hope this helps,


Thank you for your fast and kind response.

  • Yes Enttec works perfect in other laptops with MPC
  • Fixture is patched in universe 1 address 1
  • DMX output window show dmx sending

Firmware is in 1.15 (attached picture)

Okay…so just to clarify.

You have used this Enttec box on other laptops running MPC, but not this one running ONYX?

The patch, does confirm that you have Fix ID 1 patched to Univ 1 Addr 1. However, the Programmer Window, only shows that you are currently adjusting parameters on that fixture. I would like to see a picture of the DMX Input/Output window, that will show what’s supposed to be actually outputting. While most of the time this is what’s in your programmer, if you have “Inhibitors” or “Preview” active, this will alter that state.

See attached.


This enttec box have worked with other laptops running MPC, this is the first ONYX install so far.

Attached the dmx out pictures requested

Okay. I was able to plug in my Enttec and do some checking. I also have a copy of Pro-Manager 2.43. However, my setting show firmware 4.8 and it was updated through pro-manager. I couldn’t find that firmware on Enttec website - so you might need to call them and see where to get a copy of 4.8. Not sure if that will help, but that’s a start.


What OS are you using?

Win 10 Enterprise 64-Bit. We will upgrade to 1809 at a later date on my machine. But I have 1809 running on other machines.



Let me install a fresh Windows 10 OS and double check, I´ll let you know

I updated the OS to a fresh updated Windows 10 pro no errors on installation, fresh Onyx Onyx 4.0.1010 install and no errors during installing process, still not working!

Tested with pro manager, and light Works, it means that Flow throght laptop ->usb cable -> interface -> dmx cable -> fixture, works

Any thoughts?

I went to https://www.ftdichip.com/Drivers/VCP.htm and downloaded 2.12.28 VCP drivers for Windows, and updated the usb serial converter driver, it gave me a sign saying “your installed driver is newer than you want to install”, after that it started working… somehow it worked!

twilight zone

1 Like

Thanks for reporting back. I’ll keep that in mind in case I ever have a similar problem.