ONYX- NX DMX Driver Issue.

Hi All,

I am having in issue with my new NX DMX device where the device is showing up in windows, but its saying: “Driver is unavailable”. In turn, the device isn’t showing up in ONYX. The NX DMX A and B lights are green, and the status light is red.

I’ve looked all over but I can not seem to find a driver for the device. Is anyone aware of one, or have any suggestions for a fix?

I’m running Windows 10, ONYX Version 4.0.1010.0, with an M-Touch and Enttec.


Yeah I’m having the same problem with no luck.

You need to update to ONYX 4.2.1045 for all NX hardware.

Thanks you! I updated and that fixed the issue.

Hey, I have the same issue with onyx 4.4 after updating windows 10. Any solutions out there besides me trying to roll back windows?

I’d reinstall ONYX if the driver is not working correctly so it gets refreshed.

Uninstalled oynx, uninstalled obsidian driver and libraries just for fun, reinstalled onyx, no dice

Windows recognizes the device but complains about no drivers

On my linux machine i get an error in Dmesg reading device descriptor read/64, error -71

Product and manufacture fields populate well and it actually shows an orange status light in linux rather than just red status light, or sometimes red status light and a and b lights green

Also installed ONYX on a new machine, still no dice, could it be a firmware issue with the nx-dmx2?

I guess ill try to test one in store somewhere

it could be a defective device or bad usb cable

Checked Usb cable is good and tried several, is there a specific RMA process, I’d hate to return it and not have it go to be checked or sent to engineering.

It’s brand new used for one show it’s upsetting that it couldn’t survive quarantine in it’s box during covid season.

have you tried a different pc? we have not seen really any failures in these, and its a design that is quite proven for over 10 years.
Its almost like you have a bad usb driver or security signature issue

Installed ONYX on my newer machine, no dice. Installed ONYX on a much older device, and it magically works!

Rolled back updates on my onyx machine and reinstalled ONYX again no dice… So then I got creative…

Only uninstalled the drivers with the nx-dmx2 plugged in, then tried to reinstall onyx, it installed the driver, then asked me if I wanted to remove ONYX to which I canceled.

It now seems to be behaving correctly!!

I am on a Windows 10 preview and there are no known issues with the driver. Lets hope it stays like that!