Onyx sACN Issues on M1 Console

Just upgraded our Martin M1 today to the latest 4.2.1045 software. Looks like there is a MAJOR issue with routing sACN through this version. We were able to get it to work, but as soon as we rebooted the console, we lost connection and were unable to get it back. Just downgraded to 1010 OS and it seems to be working. This really sucks because I just lost an entire day of building shows for 1045 and they won’t work on the 1010 OS. Can you guys please get this fixed!

Anyone else having luck with sACN on the M1 on 1045 OS?


Could you explain what you mean by routing through? I used sACN for several days during firmware development of a new Elation fixture.

It loses the connection to sACN after rebooting and then won’t find it again. Could this be a windows update issue since we have an older M1? The newest OS works just fine when using my windows 10 PC, but it has major issues on the console. I think this is a bug though… I saw a couple other posts talking about this. I spent all day yesterday and only got it to communicate with the lights twice and then both times it lost communication after reboot!

Another FYI… 1010 seemed to be working fine. Just tried to fresh install 1045 and on the fresh startup everything worked. As soon as I rebooted, there is no connection to the lights on sACN. All the IP looks good and all the toggle switches are on…just no communication at all. Definitely feels like a bug.


This will seem like an “odd” request and possibly a “work-a-round”, but after a reboot, when you go to the sACN settings and everything looks “good and all toggle switches are on”. Please try this.

Turn sACN off, hit apply. Wait a few seconds. Turn sACN on, hit apply. See if you get control back. I have to do this on my Maxxyz Compact running 3.60.734. Anyway, just a thought for you to try.

Hope this helps,


Thanks for the suggestion @Watson. Already went down that path though and no amount of on/off and apply made any difference. Went out and bought a license for ONYX on the PC next to the console and am just running the M1 as a slave to the PC for now. Hopefully the bug can be identified and fixed soon.


Just another thought, while I know it’s not recommended because of the network card “speeds”, but have you tried switching the X-net (Max Net) adapter and the EtherDmx (sACN) adapter. Just to see if it’s a specific issues with the hardware (like etherDMX card failing). I know I’ve swapped them on an M2Go for testing purposes if I only have one network line available.

Also, have you tried a network “monitoring” solution to see exactly what is (or isn’t) getting output. Like sACN Viewer, DMX Workshop, or ArtNetominator? Or have you tried a network ping on the adapter that is causing issues? Just some other thoughts.