OSC Problems

I am trying to send OSC commands to onyx through another piece of software.
I feel like I’m missing something obvious but this is what I’m sending
and this is how it is setup in onyx

If i use an OSC monitor on the port 9001 It picks up the commands im sending when i move a fader and it also picks up the feedback from onyx when i move a fader in onyx. However the two programs are not communicating and moving a fader in one doesnt affect the other.

Any help would be greatly appreciated,


The OSC is coming from the same device that Onyx is running on, is there a way to make this work?

I’m sorry, but I don’t know. I’m sure that official technical support will answer competently this question with pleasure.

I am not the aforementioned official technical support, however I do work with OSC quite often.
I do not believe OSC will operate within the same device the way you have setup.

The only thing I can think of would be to setup a loopback network address (usually and see if Onyx and your other software will recognize it.

What you are currently doing is telling Onyx to look at your Wifi card, however the OSC signal isn’t coming from there, its coming from another internal software.

I was able to send OSC down the loopback but how do i get Onyx to listen on the loopback address?

I think he meant that you have to install the KM-Loopback adapter driver. For some reason Onyx won’t use as the loopback. So it’s necessary to have the virtual driver from Microsoft installed, which is also necessary for Artnet & SACN loopback. Onyx will automatically configure the virtual network adapter in settings if you wish.

Also, perhaps this can help.

I’ve tried two separate computers to test it’s not the loopback causing problems.

I am sending OSC from one to the other over a Wi-Fi network, I have OSC Monitors on both showing what they are sending and receiving and that is all good. I think it must be something I’m not setting up correctly with Onyx at the moment the device space is 001 but i’ve also tried 001 and the input IP address is the IP address of the laptop sending OSC and on that laptop the outgoing IP is set to the address of the Onyx PC. Any Ideas?

Thanks for the help so far guys

Actually when I move a fader in Onyx I am getting OSC feedback so the connection seems to be fine, maybe it’s the OSC commands that I am sending.
I tried sending /1/Programmer/fader5 which I found by using the touch OSC editor and seeing what the first fader on the Onyx Layout was sending.
I’ve also tried /Mx/fader/4203 because that is the address that is moving in the OSC monitor when I move a fader within Onyx?

Again any suggestions would be very appreciated

Perhaps the release preview …48 has fixed this problem which has been reported in another thread. Search for TouchOSC and you will find it. I suggest trying the preview.