Placing Combined Fixtures in 2D Plan

Hey all,

Fresh ONYX show file. Create 4 Roscoe i-cue 8-bit fixtures, which come formatted by default as “combined fixtures”. The Roscoe itself is a moving mirror, the combined part is the assumed dimmer channel. When I try to place these fixtures on a 2d plan, the red line shows as I draw them in, but they never show and they never get placed. Any idea why? Video attached.




Show file: TEST.OnyxShow (1.4 MB)


I’ve tried your file and a new file myself and have the same problem. Are you able to patch any other fixtures in your show and add them to the 2D Plan? I was not successful in that either.

@Ofer_Brum are you able to take a look at the Roscoe I-Cue (8 bit) profile? Something is causing some 2D Plan issues with this fixture. Or is there a better way to request this?

Sorry I couldn’t have been more helpful,


Okay yeah, I’m seeing that now, too. So this whole thing started with what I thought was a balked show file. Thought maybe it was corrupted. I couldn’t create shapes or add anything in 2d plan. So I started a new show file from scratch and I could add to the 2d plan UNTIL I added these i-cues. You’re right…if the i-cue is in there, it stops everything from being added to the 2d plan. So my original file wasn’t “balked”. I just went back into that original show file & removed the i-cues, and now I can add fixtures to the 2d plan there, too. I first unpatched them, but that didn’t fix anything. I then went and deleted the fixtures altogether and BOOM…all those attempted shapes and fixtures suddenly showed up on my 2d plan! See the attached image. @Watson, if you go into my test file, attempt to add a couple shapes (it won’t let you), and then go into the Patch area and DELETE the i-cues completely, then return to the 2d plan, you’ll see those shapes that you attempted to add earlier are suddenly there.

So the i-cue fixture is causing this bug. I hope we can get an answer from @Ofer_Brum about this.

Hello Chris,

Please send any profile related issues, using Profile Request form. Set Type of request, to Library issue:

Revised I-Cue profile has been posted here:

Best Regards,
Ofer Brum
Onyx/M-Series Fixture Library Support


Thank you SO MUCH for working on this. This new fixture profile now has a setting to choose between mirror/dimmer/full. I guess the full one makes sense, but the thing is this fixture is just a mirror. The dimmer for the light is on a separate DMX universe altogether in my case. So if I choose Full, it’s sending the intensity control to the mover head, not the actual dimmer unit which is separate. At least this way I can put the Rosco in mirror-only mode and control the dimmer separately, but the previous setup where it’s actually a “combined fixture” with a separately-addressable dimmer fixture was actually how it should be set up.

**Fixture library edit request made through the Profile Request form as instructed. Thanks, I wasn’t sure if this was a fixture profile error or something in the 2d plan portion of the actual software itself.