Pop up dialog glitch 4.8.1240

Fresh update on my desktop to the current release version (4.8.1240)
I was experimenting with 3 windows of onyx on a super ultra wide monitor.

I now can’t access the record / clear / load pop up screens
Even when back to 1 window, after a restart.

I just get a black rectangle where it’s supposed to appear and I can’t access any of the functions.

Anyone else encountered this?
Kinda critical functions!

Video attached:

I always have negative experiences when I try the updated versions of onyx…
(however, I’m glad the snap feature is fixed and more prominently displayed!)

I’ll keep other bugs to other threads

I’ve tried new showfiles, I’ve uninstalled and reinstalled onyx. Bug still remains.

Onyx is simply unusable now on this computer and I was supposed to program a show for someone today :confused:

First time for everything, in 15+ years of that toolbar I have never seen it not render.
What graphics card is in that PC?

rtx 2070 super

It was working ok (other than the dylos glitch in another thread)

but yeah, this went wild after I experimented with the multi display window feature

I’m running an ultrawide plus two rotated 1080p screens of an external GPU for a long time without issues.

What specific display feature are you referring to?

I’ve also haven’t had this pop up dialog ever disappear for me.

And yeah, I’ve used multi monitor setups many times in onyx just fine.
It’s a feature I think is a strong point of this software.
(man… ma2 onpc window management… ever spent time on that? it’s awful)

in this case, I tried activating 3 virtual displays, as this monitor is 3840x1200 32:10 ratio
and I could fit 3 side by side.

interestingly, virtual keypad is on top of it
But everything else in beneath it (even web browser)

I’m updating graphics drivers and all that jazz

though a directX benchmark thing performed fine

no change

updated to the beta, still broken for me

Maybe this PC needs a format.

Hello, could you restart the Onyx software and once the show has loaded, before doing anything else, go into menu, navigate to Tools (under System), then the Diagnostic tab and choose “Start Logging”. Then issue a command that shows an affected popup and as soon as the issue has been confirmed, navigate back to same menu location and press Stop: a file browser will appear to store the log file: please PM that one, so we can hopefully get some insight what’s causing it.


Didn’t see this several months ago

Trying the beta on this PC (it’s my main home desktop PC, not one I regularly take to gigs)
Running into the same issues.

I’ve recorded a log file and I’ll send it through to you

Just checking in @gert_leunen

Did you receive my log file?

We did, but unfortunately couldn’t find anything relevant: nothing appears to fail. Guess we’ll need to look out for an ultrawide screen ourselves to see if we can reproduce


yeah, it is an unusual resolution, I hadn’t considered that as a potential cause.

I can do some tests here to rule that out…

  • I can try another PC through this monitor
  • this monitor has a mode where it can act as 2 independent 1920x1200 displays, side by side from separate inputs.
  • I could also set up a regular 1080p monitor on this PC

I’ll report back after trying some stuff.

Splitting it and running it as a 1920x1200 display makes no difference

Changed the resolution, restarted, made sure no window snapping assisting apps were running - if I get it running successfully on this monitor on another PC, I’ll try installing these apps and see if this breaks anything I guess!

But yeah, initial test, no change

Had some bizarre UI glitches in photoshop yesterday!
Also one of the windows screen shot making apps… it’ll transpose the image about 960 pixels to the right

I currently suspect it’s a 3rd party window management tool - if so beyond the scope of what I could reasonably expect you guys to help trouble shoot!

Probably doing non standard tricks with the ways windows draws windows or something

I’ll post screen shot when I’m at my pc for reference


It’s a program called “Virtual Display Manager” (www.ishadow.com)

Weirdly, quitting the app or disabling it, left the issue in effect

Had to uninstall

I’ve flagged it with the developer