Problem connecting Onyx to Capture demo

Hello everyone.

I have recently downloaded Onyx and I’m trying to connect the program to the Capture Demo file over artNET. I have found and followed every resource, instructions, tutorials, you name it and nothing is working.

I dont have a lot of experience with more professional lighting solutions, and I was hoping to use Onyx to learn. At the moment all I have is the Onyx software(the most up to date via the download page), and the Capture demo. Both are running on the same PC, with no external nodes.

When I first downloaded the software, I tried using the MSD demo. Unfortunately, it didnt match up with the Onyx training file, and once again I could not find an Onyx file to download for it. On first boot, MSD appeared to have a connection to Onyx, however as stated, it was not the same file so things were a little screwy.

I don’t know a whole lot about networking and the like(perhaps that’s my issue) but I have changed the IP through Onyx to a 2.x.x.x with a subnet of The connectivity options in Capture show the same IP, and the settings on my PC show the same IP.

I’m at a loss. I would really like to start learning with Onyx. Unfortunately I cant shell out $500 plus for the full Capture software and hope it works. Does anyone have any info that could help?

Thanks to whoever reads this!

(Edited link.) Did you install a virtual loopback adapter? It’s a virtual network driver.

The download from the link you posted didn’t work, but I managed to install it via the device manager through windows. Worked on the first try. Thank you so much!

1 Like

Sorry. Lazy link. Not knowing your OS I used the first Google result for the KM-Test Loopback adapter. I updated the link to a video tutorial for Windows 10.