Release Preview 4.2.1048

The previous build had a corrupt file which broke some functions, especially networking.

This is now corrected and this installer is targeted for release on the support page next week.

Release notes for Onyx
© 2019 - Obsidian Control Systems

4.2.1048 (7/06/2019)

Added software support for NX4 and NX Touch
Fixed Art-Net RDM issues
Fixed MIDI (timecode) test application
Fixed DMX IN mapping change requiring restart
Fixed LED feedback on virtual submaster

4.2.1047 (15/05/2019)

Improved MIDI (fixed timecode jumps on NX2/NX Wing)
Fixed DMX IN issues
Fixed calibration parameter display M2GO (HD)/M2PC
Fixed external display on M1
Fixed sorting by universe or address

4.2.1046 (25/04/2019)

Improved command execution times
Improved DMX startup
Fixed unpatching when patching fixtures to already assigned addresses while selecting UNPATCH as conflict resolution
Fixed occasional error popup when switching screen layout
Fixed internal DMX ports not showing/working on NX2 / NX Wing and re-initialized M2GO HD / M2GO / M2PC
Fixed importing fixture not including accessory information


No Good for me I’m Afraid, NX2 console with a DMX in on port 1 so the venue staff can use an old dimmer desk (very non technical people) DMX in is only working for channels mapped to dimmers. will not work for channels mapped to cuelists. Have had loads of problems with DMX in. when we 1st got the console in April DMX in Would not function at all. Updated to 1047 which cured it all for a few weeks and then back to not working. Just updated to this 1048 and still exactly the same. Have tried different boards for the signal in. Different DMX cables and converters.

It seems that where i have mapped the Zero88 faders to Dimmers rather than a cuelist of overide they work fine. But Zero88 to operate overides does not (although it did work fine for a few weeks) I have checked Menu>DMX In>Playback Control>active is On, Source Port is 01, Starting address is 001

Menu>DMX In>port 1 Internal DMX 1. recieving 42FPS (<–Is this correct?)

Menu>DMX IN>Merger>OFF

Menu>DMX In> Mapping. DMX in 13 >24 control house dimmers not cuelists and this seems to work ok. All other DMX ins are mapped to Cuelists and can’t be adjusted. Sometimes they will launch if the zero88 has its faders set to its desired levels and you power cycle the NX2 but after the powercycle the cuelists can’t be launched or released by DMX in.

Updated to the 1048 preview and still the same

And not once have i had a response or acknowledgement of my emails to support email

Very unhappy venue owner. I convinced them this was the way to go as Our M1 has been great but struggling to justify NX2 at the moment as it’s not doing what they want or is meant to be able to do.

Happy to send a showfile. hopefully you can tell me I’ve done something idiotic and that is what the problem is.