Windows Setup install issue - M2GO HD (Onyx Build 4.0.1010)

Getting an error during the windows installation, tried multiple times and even re-downloaded the .zip/.iso to be sure it wasnt’t corrupted.
Not sure where this is coming from.

More info -
Nearly brand-new M2GoHD, installed the4.0.1006 update just fine last week.
I noticed the incremental update for 4.0.1010, but the small updater wouldn’t work at all for some reason.
No error codes, but the version number would not advance after the installer finished.

So I decided to try the full .iso 4.0.1010 version.
Which will not finish installing windows at all.

Currently re-trying the 4.0.1006 until I can figure out the windows issue.
Here’s hoping this one installs.
Check out the pics for the error I was getting.

Looking around on MS forums too, seems this may be an issue with the unattend.xml file in the windows installer? (I’m going to attempt to get the setuperr.log if I can, but no promises)

I replaced the HD file last week due to this error. Redownload it and you should be ok!

Hey Mathias!
Thanks for the reply.
So I had started this last week and got the error, so thinking along those lines, I had re-downloaded the HD file from the Box link just this morning.
I’m heading home to try downloading a fresh copy on another machine and creating an iso on a different usb just in case that could cause issues.

I can say the HD 4.0.1006 that is still posted also gave me the same issue today after a fresh download.

Is it possible the failed install from last week would be causing issues with these attempts?
And is my next step a CMD reformat of the the drive to start fresh? I don’t know how much remains on the drive during a windows install, and I’d prefer not to Brick my desk of course :wink:

Thanks Mathias, always a helpful presence!

The OS install should reformat the drive, I had this on a desk in the office and the revised installer fixed it. I wonder if you see a cached version?
Look on the USB stick, the autounattend.xml should be from 8/30/2018

So the usb I made today of course shows 9/4 as Created, Modified, Accessed.
Not seeing any date information inside the XML, but I’m not sure I’m looking in the right place.

I do see on Box that the last HD 1010 upload was 8/30, so at least here I have the newest copy.
I’ll be able to download tonight and try it on the desk first thing in AM.

Nice to know I won’t need to open the desk (yet) to get it going though =)

I shall definitely report back tomorrow AM (PST) either way.
Thanks so much Mathias!

No need to open the desk, you could boot it from any of the common rescue usb boot images and format the drive to be sure its clean.

So I’m guessing the file I got yesterday morning came from a cached Box link for some reason.
I re-created the boot usb on a different PC last night and it loaded right up this morning.

Thanks for the quick fixes on the install files Mathias, sorry I got caught in between updates!