Common PC Installation Fixes

MSVCP140.dll not found
Download and install Microsoft package:


Error 1720 “LoadDefaultShowFile script error” (Windows 10 only)

COM+ Windows System is not running due to Realtek/Dolby sound driver startup issue.
This is a critical part of Windows that ONYX utilizes for real time synchronization across the software. The issue may be resolved by Dolby in a newer driver at some time. We created a workaround.

Confirm by launching “Component Services” from the Start Menu

Open Computers/My Computer. A Red Arrow will show next to the monitor icon.

Selecting COM+ Applications results in Error code 8004E00F

Fix :
Change the DOLBYDAXAPI service to delayed Start.
Apply this registry file to the PC and reboot.
FixCOM Dolby_Realtek.reg (590 Bytes)

Check the the COM+ system, no error should show.

Extra steps to check (and fix) are:

Install ONYX only if the COM+ error is solved.


Fixing that underlying 8004E00F error is easier said than done.

I installed the registry tweak. No difference.

Lenovo X1 owners are experiencing the same problem but that’s due to a smart standby issue.

Both my systems that are failing do have Realtek HDA, but do not have the Dolby services installed. Delaying the startup of the realtek did not solve the issue. The two systems only have 2 things in common - the CPU manufacturer is AMD and they both have realtek HDA.

I am afraid that with Windows, this issue for me is never going to be fixed. Does Elation have plans to remove the necessity for COM+ in the installer?

For me from a fresh 1803 install, Windows Automagically installed 21 drivers between when COM+ worked and when it didn’t. I don’t have the patience to disable them one at a time till I find it.

I know this is a big ask, but you would think a big version change would come with an updated installer. With Win 10, it’s increasingly more challenging to get a single installer to do everything. I have one program that requires me to install the pre requisites individually.

I am having the same issue - 1720 error. Installing the registry tweak makes no difference. Running the Component Services after installing the tweak and rebooting till shows the 8004E00F error.
Running the Onyx install package after that still returns the 1720 error.
I’ve had two support phone calls and two email exchanges and this is the only solution I have been given - and it doesn’t work.
I’m installing on a brand new HP Envy with no other software installed (other than pre-installed). I’ve even wiped and reinstalled Windows twice to be sure there were no remnants of old installs.
Can someone please help? I’m ready to return the M-Play and M-DMX and go with another solution.

I have the same problem with my HP Elitebook 840 G2 i7-5600U/16GB/512GB SSD. with a fresh Windows 10. couple of HP drivers for fingerprint, touchpad and networking.

1 Like

I also have this problem, i tried clean windows, with no luck

For problems with HP computers, check this post, it saved me:

Hello, could you please explain how to do it? I have this problem and I cannot Install or uninstall the previous install.

You can use Onyx cleanup tool to uninstall.

Hi, did you solved this issue by yourself?
You can disable this driver in services on windows. just right click the service --> properties --> dropdown menu --> set this to disabled --> apply and stop the service. then you need to restart your system.

I hope this quick explanation works :slight_smile:

Hi, I have a slightly different error message to the one shown in the image above.
Mine reads:
“ONYX Error 1720. There is a problem with this Windows Installer package. A script required for this install to complete could not be run. Contact your support personnel or package vendor. Custom action CheckUpgradeability script error -2147467259, Msi AP…”
The difference is the “CheckUpgradeability” where the image says “LoadDefaultShowFile”.
I have tried to find & fix the issue the way shown, however, my COM+ is running fine. I have also used the “FixCOM Dolby_Realtek.reg” file and still had no luck.

Rather looks like there’s a leftover from a previous install or a required packaged didn’t get installed. Please PM me the log file (most recent MSI*.LOG in %TEMP% that contains the text Onyx.MSI)

My onyx installer gets stuck and I have left it for over 24 hours and it hasn’t moved, I can’t Install the program.

I get this error when trying to install on “This User Only”

I Closed that error a few times and then it continued/finished installing.

Now when I try to load the Onyx app it starts another installer that has 3 different issues:

“Invalid root” sounds rather harsh, seems like the installer can’t access the registry because of a permission issue, or it can’t obtain administrative priviliges, or access is actively prevented by anti-virus software.

Any chance you can remote in to my laptop to try and fix it?

Sure, PM me your AnyDesk ID

Just bumping this, I can’t seem to get the installer to work. Does anyone have a solution for HP machines? What about going back in the archive to an old install?

Screenshot 2022-07-13 192155

whats the error? some newer pcs have an issue with a new style of SSD drives.

Trying to get through the installer

I’ve tried both installing for current user account only & otherwise

I get to about 60% in the install shield wizard before I get this error

Screenshot 2022-07-14 100912

I tried the various solutions in this forum but none have worked for me

My Machine is a HP Pavillion x360 2-in-1

1 Like