ONYX Beta 1212

Hello !

I’m coming back with the same question about artnet loopback.

Nodered is no longer able to send Artnet to Onyx on the same computer on the Beta 1212.

And I actually did some more testing and only sACN works when using the microsoft loopback Adapter from Onyx to Onyx. The exact same settings on Artnet show “No Signal” in the DMX In tab.

Is it a beta problem that will be fixed or maybe a problem coming from Windows ?

Thank you !

Note: This only occurs with old groups created in previous versions, groups created in 1212 show color correctly


désolé je ne parle pas Anglais.

Je suis un utilisateur Onyx “confirmé”
Avec la beta 1212, après avoir créer une nouvelle zone Dylos, impossible d’envoyer du contenu dans des fixtures.

Autre problème, par exemple avec des Robin Pointe que j’utilise, les channels color, gobo, prism, effect sont en FADE alors qu’elles devraient être en SNAP

Merci d’avance

Hi Loanrix,

I have a loopback running using the virtual Microsoft loopback. I have no issues with the current version. I assume it has something to do with node-red. For me, both sACN and ArtNet work all the time, reliably.
Hope this helps you narrow down your issue.

I was not able to use a loopback from DMX Workshop to generate a test signal for Artnet In for Onyx on the same pc. Please explain how you set yours up?

I went to the device manager, added the legacy KM Loopback adapter from Microsoft (action>add legacy hardware>add manually>Network>Microsoft>Microsoft KM Test Loopback adapter),
I then went to my network options and changed its IP to be static, although this is not necessary.
I then enable this network device in Onyx and it works fine from thereon.
I am able to run visualisers like Sunlite MEV or ArtnetToDMX or just the artnetometer perfectly like I was able to in the previous versions.

This is about Artnet Input, not output.


It’s really interesting that you can make it work with 1212 ! Using the KM-Test Loopback Adapter, I can only loop sACN, not Artnet. Same settings as sACN, just changing to Artnet and it shows “No Signal” in the DMX In tab ( I tried broadcast, override IP,… still no signal ).

On my actual set up, NodeRed is sending Dmx Adresses to Full via Artnet, loopback on the same PC.
Worked fine on 4.4.1193 but stopped working on 1212. We actually rolled back to 4.4.1193 and it worked right away !

So it really looks like something changed with 1212 and Artnet.

Is it no longer “listening” to internal Artnet ?

Thank you !


1 Like

My bad, I am sorry. Overread that

Highlight isn’t working correctly for a particular fixture, U King / Mini LED Moving Head / 14 channel mode.

  1. Renaming Cues in the Playback buttons isn’t working for me. After immediately recording a cuelist to a playback button it allows you to type a new name but doesn’t save it. After doing something else it may remain grayed out.

  2. Recording from one edited cue to another results in not being able to clear the programmer. Clear Clear doesn’t work. Nor does the backspace. Only pressing Undo stops the Update from blinking.

For example,

  • Select a cluelist / Edit / Cuelist #.

  • Select another cuelist / Record / Cue # /Clear /Clear

The Update button remains blinking. Neithe rClear nor Backspace clears the programmer. Undo clears the programmer.

If you select a Uking Fixture, open the defaults view and select the default highlight, does nothing happen? Perhaps select all UKing Fixtures, set intensity to full and record (merge) it to the highlight preset in the defaults pane.

I know there are some inaccuracies within the profile like the colour and gobo wheel. I have corrected these along with some other things in the profile I added along this message.
This should also fix your intensity issues.U KingMini LED Spot V4.Fixture (85.3 KB)

Thank you. I’ll try this once I return to the Venue. Not sure if this shows in a visualizer.

Mode Sync in FX and group selection
I tried around with some FX today and noticed, what I find, weird behavior of the FX engine.
Innitially I planned to apply the same swing and shape on 4 fixtures and then inverse the effect direction/Mode. When lights are static at settings change it all works fine and they are synchronous.

But when lights are moving and I change the mode they do not move synchronously. That is all good and fine. If I now revert back to the same mode as the other lights are, the selected portion however, they somehow sync to the rest?

I don’t know which of the two is the odd one out. It doesn’t matter If I use the grouping tools or not.

Effect 2 in Dylos gets stuck in rotation. After clearing and snap+rel FX2 stays rotated. One needs to move it again clear the programmer, move it some more, clear and it get unstuck. Using NX2.
Also FX1 tiles change slower than other parameters as well as zoom x center in source. Nothing major, but weird

sorry. but did you fix the cue following by first trigger, on a xnet show on backup console in the next release?



This has been fixed in the upcoming build

Not just yet in the upcoming build, but still planned to be fixed in the release

This loopback should work in 4.5.1213