ONYX Beta 1212

Yes, they are in correct order after being restored.

Sorry, I should have mentioned that.

Assuming you’ve set your fixture delay times as 1>2>1, and are then trying to modify the cue delay override time: the sequence of time programming is not available at cue level, the range presented there is simply min > max delay times, allowing you to change the min and the max which will linearly modify the times programmed inside the cue (order agnostic), so only one through (’>’) is allowed at that level. Completely removing the times because of a faulty command is a bit dangerous, though, and we’ll look at ignoring the extra through steps, or the faulty command altogether

hello, what about dylos live video input (spout/ndi)?
after a few month of testing dylos from all sides and with all load and pressure we can get in testing, we have to tell everyone,
we only can use dylos in our shows, synced to video and other efx with a realtime video input layer.
without this, we have to messure all the color values out of video content (which is no problem in isadora, also in realtime, but it is additional work in a big count) and give it back to onyx in traditional way.
so dylos is not able to follow external video content,
please, this is very important.



Video Input was not part of the 4.6 development, it will have to wait for later versions. There were many other Dylos developments that had to be completed with a higher priority.

I’ve just re-checked the bug mentioned by @David_Henry in the 1211 thread. As far as I can see, the problem is present in 1212.

Here is a sample show file:
Test_2021-04-21_1450_Build_4_5_1212_0.OnyxShow (4.8 MB)

Have a look at the ‘Main show’ cuelist. The first cue simply gives the lights some color and intensity. The second cue has DyLOS values. When you run the cuelist, it all works fine. The colors go from Red (cue 1) to Blue (cue 2). Now Edit cue 2, and switch to the 2D View. You’ll see that the lights are Red, whereas I’d expect to see them in the Blue tones controlled by DyLOS.

…we find out, the only way at the moment is a cue before every use of dylos, which set the main intensity of multipartfixtures to full, prepare the zoneslot and fade in the zoneslot intentsity with a delay. best we found with a second empty zone below, so this one blocks the full intensity of fixtures before the zone with content is fade to full.


1 Like

hello, generator scrolling does not work in ervery case, sometimes yes sometimes no.




…sorry, we had one laptop left with .1211.
our fault.


Where is the place to report bugs?
I found several together with this beta and the new fixture library and NX4 consoles’ encoder wheels in FX situations.

2D plan Issue:

Beams of RGB fixture appear black for some reason. Fixture Profile (1.7 KB)
Problem is solved. Loaded fixture into editor and linked the RGBW channels to additive Red,green blue and white presets.
Presumably due to the new databse swich, I also had to relink pan and tilt to make the fixture show up propperly in 2D view…

hello, generator scrolling does not work in ervery case, sometimes yes sometimes no.

I can confirm that on the NX4

The place to report bugs is this topic.

1 Like

…we can comfirm that this problem is gone with 1212.


(bit of a repost from FB)

I am using the “Trigger” macro to trigger a cuelist. This macro requires a cuelist and a cue number. If no cue number is entered, the function defaults to Cue 0 and triggers that specific cue in the target cuelist. If the Trigger macro is used again on the same cuelist, it will again play Cue 0.

The documentation states “Same as pressing Go button on specified Cuelist.” However, when you press go on a cuelist that is not playing, it starts the first cue. When you press the Go button again, it advances to the next cue in the cuelist.

Is there a way to have a macro trigger a cuelist as though pressing the Go button as described in the documentation?

In other words:

  • First time the macro fires it triggers the first cue in the cue list because the target cuelist is not running

  • Second time the macro is fired it advances to the next cue in the target cuelist because the target cuelist is now running

Onyx 4.5.1211.0 for reference. (I know it’s pre-release, that was an accident, can replicate this on production-level code if needed)

Just checked with version 4.2.1057.0, which is working properly. This appears to be a bug in the beta. Looks similar to the Playback offset change that has been observed by ShowCockpit users.

Also checked version 4.5.1212.0 and the bug remains.


There is no Cue 0 allowed, maybe its a corrupt list. Post a screenshot of your cuelist and the macro you use.

In the NX2, I have no way to create palletes, I click on the pallet slot in the user folder and can[t get the menu to come up. I tried edit click on the slot anter and still no success.

In the PC I either right click or click hold and get the menu

maybe the update to 1212 didn’t take? Check the about menu.

about menu says software version 4.5.1212.0

What keys do I need to use on the nx2 to create the palletes?
I tried edit, record, update, load and nothing happens

A new showfile seems to be working correctly. Screenshots are from the current showfile. This is happening globally, regardless of cuelist or cue.

Problem solved: hit and hold edit while touching the desired slot.