ONYX BETA 4.7.1234

Hi everyone

We have reached the point in the 4.8 Development cycle that we are ready to start the beta testing process.

This version can be installed currently as an update to 4.6. However, it will require a full OS install on consoles when released. Included below are the installer and full OS.

ONYX 4.7.1234 OS: Obsidian Control Systems

Please review the beta and specifically check the following options

Wing IDs
Quickview Button

Install and Uninstall on PC Systems.
If anyone has a PC that doesn’t install ONYX due to an SQL error we want to know if this version works for you and the error no longer appears.

Please provide any feedback (bugs, issues, comments) for this version by replying to this post to keep everything in one place.

Happy Testing!

Release Notes:

4.7.1234 (7/07/2022)

  • Dropped SQL server instance sharing: each user will run his own instance against shared data files; this should eliminate login errors during installation
  • Various fixes and improvements

4.7.1233 (6/07/2022)

  • Fixed XNET connection reliability issue
  • Fixed rendering (color mixing) channels that are not linear across the entire DMX value range
  • Various fixes and improvements

4.7.1232 (24/06/2022)

  • Added support for NX1, NX-K, NX-P
  • Added support for wing ID on virtual panels
  • Improved and unified device management (configuring wing ID, DMX universes)
  • Playback fader flip (1-10 <-> 11-20) is now applied per wing ID (instead of global)
  • Multi-function button mode (Play, F-Keys, Base, FX) is now applied per wing ID (instead of global)
  • Fixed new fixture types in library update can only only be added after restarting software
  • Fixed wrong fixture types matching on CITP import from Capture
  • Fixed programming issues when using encoder to reach zero while operation mode is absolute (jumping to full)
  • Various fixes and improvements

Non of previously announced features, such as:
New Default/HL Preset type
PT Offset
Sound In

Included in this build?


No, different branch, didn’t risk to keep NX1/NX-P/NX-K waiting in the factory when ready before these new features would be good enough for release (as it is turning out). Coming very soon, though!


Thanks for clarifying, Gert! :slight_smile:

So, all these mentioned will be available with next Beta 4.9?



Issue with Quick view when scaling the window
small on PC sys .
Once scalled the window small click on the cross in the middle,It Will resize and scale parameter window but It eliminates the entire Quick view section,when you enlarge It again ,there is no way to have that view back.
Even if you reload the view,only action that works ,is that you need to re start Windows and Onyx, otherwise if you close Onyx ,and atemp to restart It Will not open.

Work fine new installation,

But, we reported a important bug with cloning parameters, it will be solved in this build ?

It will not be resolved in 4.8, this release is very specific to NX1.

Hello to all on windows 11 why am I getting always this error?
USB stick 16 GIGA.

Then I am also trying also with a 64 giga usb stick ,and it’s about 28 minutes that it’s running and still not finished!

52 minutes to create an Iso ?

Try the full tool, how long does it take?

Rufus - Create bootable USB drives the easy way

Yep already use that I thought you where interested in enhancing the tool.

whats the speed with the full rufus version?

Tried that yesterday night Matthias ,but it wasn’t for sure 52 minutes.

15 Minutes using Rufus

No difference with the OS tool


Your stick may be “worn” that happens with the OS installs. Also make sure to use USB 3.0 drives and ports.

@gert_leunen , @mgerardi, and @Matthias

I believe there is a bug with the 2D Plan view when selecting groups consisting of either parts only or masters only. I have noticed that it can only be selected when the “Master Only or the Master and Parts” filter selection is selected. In 1226 it was possible you could select a 2D Plan group using “Parts Only” also. There also seems to be an issue with storing the 2D Plan view with the parts only selection method. It appears that you have to switch to master and then back to parts to get it fully to work. Still trying to see how best to capture this. Hopefully this video comes across. Let me know if not.


Hope this helps the development,


WINDOWS 11 with latest ISO

This version took about 45 minutes and stopped at the end with nothing opend!

Try using a different thumb drive. Most of the cheapo drives have horrible write speeds.

Thanks for the report, we’ll have a look. May not make it for the 4.7 track, unfortunately


Received this error while trying to install

Screenshot 2022-07-15 122629

Any advice?