ONYX Beta 4.9.1251

Hi Everyone,

Please update to the latest beta and review the improvements outlined below.

As always, please keep all discussions and comments about this beta to THIS forum post.

Happy testing!

4.9.1251 (15/05/2023)


Added target assignment of reference processors to F-Keys

Added support for Ableton Link Quantum Phase Synchronization

Added support for changing the tempo in an Ableton Link session

Added support for reverse playback for synced media playback and generators

Extended Beat F-Key assignment to any beat-tap processor

Fixed importing fixtures using CITP on non-English systems

Fixed fixture range selection issues

Various fixes and improvements

4.9.1250 (18/04/2023)


Dropped 32 bit driver support

Updated to SQL Server 2022 for support continuity

Updated to latest CodeMeter, NDI and Visual C++ runtimes

Completed (audio, beat) input processor workflow

Added Ableton Link support (input processor)

Added MIDI Clock support (input processor)

Added beat-tap processor (replacing former global beat for chases)

Added reference processor (to decouple source input slot programming in presets and cues through indirection)

Added metronome visual feedback for beat rate

Added “Copy from” between highlight/lowlight presets

Improved audio beat detection accuracy

Fixed (Capture) visualizer focusing via CITP while offsets have been configured

4.9.1249 (23/02/2023)


Notice: loading show files created with the previous beta (4.9.1248) will require to re-select audio input channels and/or turn NDI devices off and back on if they are used by input processors

Added beat detection sync into media playhead and chase playback (beat triggers, next to global)
Fixes and improvements to input processor workflow
Fixes and improvements to audio input processors
Allow P/T values in highlight/lowlight presets
Default values view will only show changed values
Aspect ratio improvments (covering masks)
Aspect ratio fixes for still images, rotation and scaling
Fixed live thumbnails not always rendered correctly
Fixed “non-selected fixtures” option on CLEAR being ignored when no fixtures are selected
Fixed playback fader buttons 11-20 and F-keys not working on NX-P when its Wing ID is not zero

4.9.1248 (13/01/2023)


Added aspect ratio control
Added multi-select for audio input channels
Added output override feedback to live output
Improved DyLOS input processor management
Improved DYLOS input processors’ accuracy
Improved parameter-level parking
Improved default value editing

4.9.1246 (19/08/2022)


Added input processors to DyLOS for converting external inputs into modulators (triggers pending)

  • added video and palette input processor (NDI; aspect ratio channel/parameter not bound yet)
  • added audio input, filter and analyzer processors (NDI, ASIO; multi-select audio channels pending)

Added output overrides as special presets that are edited in dedicated programmer context (“copy from” to start from regular presets pending)

  • added parameter-level parking (value feedback in parameter panel still being tuned)
  • added channel-level offsets
  • improved default value editing (clear doesn’t work yet from popup for input processors, feedback for default editing still being tuned)
  • improved highlight/lowlight editing
1 Like

hello, thx for the development.
can you please explain this:

Added reference processor (to decouple source input slot programming in presets and cues through indirection)

a little bit more!?


  1. Can you make the pop up window in Highlight feature “copy from” bigger? Come on please some of us are getting a bit old! = )

GERT morning ,to be able to install Onyx on a windows 11, I was obliged to use the “regedit” feature, unistall all of obsidian folders, then in the control pannel, I also unistalled the “driver package” otherwise it would not install on 2 differnt pc !

In a slot, you can choose to assign a processor of type “reference”, which literally does nothing but referring to another slot/processor. This way, you can change the “ultimate” slot/processor used in presets/cues without having to reprogram each of those presets/cues by having them point to the reference slot/processor instead and then just updating which (“ultimate”) slot/processor that reference slot/processor is pointing to.


Issues when trying to insert timing directly from the soft keypad! if I use the pc one all ok! can you please check it out! THANX = )

hello, where can we activate and manage this:

Added support for Ableton Link Quantum Phase Synchronization.


Dev is only dylos :frowning:

It’s always on once you’re in a session. A new channel was added to the beat detection processor for configuring the quantum value.

Can’t agree with that: we’re tackling the bigger topics currently (like the output overrides in this release), while integrating additions to DyLOS into the “light core” as well (like pulling the beat detection processor output into chases, but it will not stop there)


I am playing around with the tap time for dylos ,I have created different sync times starting from 20 to 120 but once i shut down and re open Dylos i find these all with the same tempo?

Hi Gert talking about the timecode, can you please add as a MACRO “PLAY CUE NUMBER " ,cause seems that if you play the timecode not in a uniques cuelist,but as individual cuelist that obviously you need to trigger via MACRO, that the " TRIGGER CL … CUE …” doesn’t work! i have tried pushing play on both before running the timecode and in this case it works! so I suppose it’s the trigger not activating the PLAY of that cue? Am I wrong ?

This is the main cuelist, that then should trigger the play of the other cuelist beside !

Sorry, I don’t want to seem negative, but There are many basic features that we have been waiting for many years., and it seems that they will never be only dylos has come, and many basic features that are standard in the industry


When I upgraded from the previous beta on two computers it wouldn’t install (after the required restart ) because of an SQL warning. After I uninstalled both SQL 2012 (I also uninstalled the driver package, although I don’t know if that made any difference) the install went through.

Hello Gert good morning! Can you guys please correct this issue in the timecode MACROS ! Please verify : So we have 2 differnet cuelist ,and both are all timecoded in my case consequently ,the issue comes up when we use in the first cuelist, the MACRO “trigger /cuelist / cue” feature, that in my casevis obviously placed at the end of the last cue. So tell you what happens,it doesn’t continue to listen to the timecode but it stops! But this happens only when in the the Macro “trigger /cuelist / cue” we insert the cue number like “cue1” ,buf if we leave the cue ,with no “number” ,it works perfectly! WHY?

this is by design and has been like this for good reasons. A go cue # forces a stop to the timecode tracking. This is for safety reasons to allow to jump to specific cues out of sequence. The cuelist needs one additonal manual GO to retrack timecode.
To trigger a cuelist and not pause it leave out the cue number.

Ok I understand!Maybe add a macro “trigger cuelist” with no cue Number? So people can think there might be a difference?

@truthcollins and @gert_leunen - I had the same issue on one of my test machines. Upgrading from Beta 4.9.1249 to 1251 triggered this error.

What I did -
Uninstalled 1251 and driver package. I then tried to manually update SQL Server 2022 and re-install 4.9.1251. This did not work. I then uninstalled 1251 and driver package. Along with the SQL 2022. I then reinstalled 4.9.1249. At this point 1249 worked again. I then uninstalled 4.9.1249 and driver package and went to the current release 4.8.1244. 4.8.1244 worked just fine. I also noticed that I hadn’t “Enabled DyLOS” when testing 4.8.1244 for a proper show file load. I enabled and added a DyLOS zone. Last I updated to beta 4.9.1251 and everything installed fine. I did not get the same SQL errors I got the first time. I have another 2 Machines to test with (one from 4.8.1244 to 4.9.1251 and the other 4.9.1249 to 4.9.1251) to see if it goes smoothly or not. If not, I guess I’ll report back.

Hope this give some additional info for things to try on a failed attempt.


My guess is that the install was trying to connect to the wrong version of sql. Since my driver version number was associated with an older release version, I also uninstalled that.

So you never uninstalled the old SQL versions?