onyx installation problem msvcp140.dll not found.

hello guys,

i have a problem installing onyx. to the end of installation i have this window that appears : msvcp104

I reisinstalled microsoft visual c++ redistributable for visual studio 2017 64 bit but no change, always the same problem. however, the msvcp140.dll files are present both in system32 and sysWOW64.

Has someone a solution ?


Take a look at the following post and maybe try the link in it.

You stated that you tried it for 2017, but the link provided by Obsidian Control takes you to a 2010 version. Not sure if kt will make a difference, but might be worth a try.

Hope this helps,


thanks watson, i’ll try this !

Hi Watson,

i tried to install the software again after have installed the 2010 microsoft package, but always the same problem:frowning_face:

other idea?


Sorry. Only other idea would be to reach out to controller supper directly. Support@obsidiancontrol.com

Sorry I can’t be of much help. If possible they may want to remote in and see what’s going on.


thanks for your answer Watson. I guess that for the moment i’ll keep my old M-PC !

regards !